Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Is there any way to make my graphics card (ATI x800) work with tvout? I know there are no proprietary drivers for this card only the opensource ones. It uses this cable for video out:

http://warningdang.dynalias.com/magento/media/catalog/product/cache/1/image/265x265/9df78eab33525d08d6e5fb8d27136e95/a/3/a31b_1.jpg

Personally I use the yellow RCA for tvout (in windows). I hope there is a way to work it out because it's a really important feature for me and one of the only reasons I boot windows.

Thanks ahead!

share|improve this question
    
If i'm not mistaken that's an S-Video out, does it work if you simply plug the RCA in to the TV? perhaps you may want to use the S-video connector. –  Uri Herrera Nov 25 '11 at 0:17
    
I know how to connect it because it works for me in windows. My question is how or if I can configure tvout with this card under ubuntu while I have only opensource drivers for this card? Simplified: How do I "tell" the graphics card to output to my tv? –  Liran Nov 25 '11 at 10:35

1 Answer 1

From the X.Org Wiki:

You can enable TV-Out either dynamically (by issuing commands to the running X server) or statically (through the xorg.config file, before starting the X server). For testing, the dynamic method is probably easier.

Enabling TV-Out Dynamically

TV-out may be enabled by using a recent driver and xrandr utility:

xrandr --addmode S-video 800x600

xrandr --output S-video --mode 800x600

xrandr --output S-video --set tv_standard ntsc

Enabling TV-Out Statically

Several options need to be specified. See the radeon(4) manpage for a description. In particular, you must set "TVStandard" to match your flavour of video.

This recipe is not definitive, but it has worked.

In the "Device" section:

   Driver  "radeon"
   Option "TVDACLoadDetect" "TRUE"
   Option "TVStandard" "ntsc"
   Option "monitor-S-video" "TV-monitor"

In the "Monitor" Section:

   Option  "PreferredMode"  "800x600"

In the "Screen" section:

    DefaultDepth  24
    SubSection "Display"
            Depth          24
            Modes         "800x600"
    EndSubSection
share|improve this answer
    
When I execute this in the terminal: xrandr --addmode S-video 800x600 xrandr --output S-video --mode 800x600 My PC LCD "turns off" but still the tv shows nothing (I checked the cable conecction). Also when I do: xrandr -q in the terminal one of the line says: S-video disconnected (normal left inverted right x axis y axis) But again it is connected physically. –  Liran Nov 25 '11 at 19:19
    
Yes the PC screen will turn off because what it does is to make the S-video the only output. –  Uri Herrera Nov 25 '11 at 19:26
    
But as I said, the tv doesn't change (still doesn't show anything). –  Liran Nov 25 '11 at 20:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.