Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Long story short: I tried compiling kernel 3.1 on Ubuntu 11.10 at the same time I had an update waiting for a reboot. Computer would boot to a black screen and would hang there. Ended up installing 11.10 on top of old install with a Live CD. Now I had a purple screen on bootup but it would end up booting. Realized Grub was the problem and tried some stuff but nothing worked. I ended up trying to install propriety ATI video drivers and since that nothing has worked, no grub menu(purple screen) and when it boots into the kernel it ends up hanging, I can sometimes get a terminal up with alt-fx. I have tried removing the ati drivers with the ati script, purging my fglrx driver, reconfiguring my xconf.org and following any tutorial I can find about fixing a broken graphics driver, but to no avail.

I've gotten to a point were it seems that the ati propriety drivers are correctly loaded but it still has no grub boot menu and won't boot into Ubuntu. I've chased down my logs and this line is from kern.log: unity-greeter[3269]: segfault at 0 ip b7245cbbsp bf9d3900 error 4 in libgio-2.0.so.0.3000.0[b71ad000+142000]

That line leads me to believe I don'T have the correct libgio-2 librairy on my system but have no idea how to find out what package has the correct version...

My xorg.conf has no errors and seems to imply the fglrxdrm module got loaded correctly. Would be a bit complicated pasting the whole file here but if it would help I'll post it.

LAstly, running fglrxinfo give me: Error: Unable yo open display (null)

Any help or link to another tutorial would be appreciated. Thanks.

share|improve this question

closed as too localized by Luis Alvarado Mar 14 '13 at 16:56

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

Best solution which I found:

  1. install lightdm-gtk-greeter:

    sudo apt-get install lightdm-gtk-greeter
    
  2. replace unity-greeter in /etc/lightdm/lightdm.conf with new gtk greeter:

    greeter-session=unity-greeter

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.