Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After an upgrade to 11.10 (kernel: Linux lucid 3.0.0-13-generic #22-Ubuntu) which probably also updated Skype to 2.2.35 (not sure because I never checked the version before) the sound that comes back from an echo test is very high pitched and squeaky. I'm not sure if when in a call if the other person can't hear or just doesn't know what they are hearing. I am using a USB Logitech C250

Audacity records fine, gmail video chat works fine, but if I start sound recorder I get a "Could not negotiate format", followed by "Could not get/set settings from/on resource". I don't know if this is a Skype problem or a wider Pulse problem.

My only real needs are the gmail and Audacity, though I have a couple of contacts that I can only Skype with.

share|improve this question
    
For me this issue was fixed with kernel upgrade to 3.0.0-14-generic #23-Ubuntu –  Dennis Dec 17 '11 at 15:51

2 Answers 2

up vote 2 down vote accepted

There is a bug open in Launchpad (have a look here)

Comment #80 helped me:

The problem is that the microphone is in the wrong sound rate by the pulse audio. As a user do the following:

gedit $HOME/.pulse/daemon.conf

and put the following line on the file:

 default-sample-rate = 16000

save it, and then restart pulseaudio as a user with the following command

pulseaudio --kill && pulseaudio --start

This should solve the problem.

share|improve this answer
    
#80 fixed Skype but broke the other things. +1 for finding this bug when I missed it and I will play around with some of this and see what happens. –  Dennis Nov 25 '11 at 13:49
    
#87 is the best work around for me, I just have to use the settings menu to start the camera before the call and everything is fine. Since this seems to be related to this particular kernel problem I'll consider this the answer and see what happens with a new kernel. Thanks –  Dennis Nov 25 '11 at 14:13
    
See also askubuntu.com/a/294923/19753 -- I've solved the issue with sound recording broken by Skype by disabling pulseaudio. –  imz -- Ivan Zakharyaschev May 13 '13 at 17:20

I had slightly different problem with Skype, but the solution might be the same.

Why can't Skype hear me?

share|improve this answer
    
Thanks, but tried it and no it didn't help. Skype is getting a signal it is just really fast, high pitch, and echoes faintly. –  Dennis Nov 24 '11 at 17:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.