Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I plug external speakers into the docking station for Thinkpad T420s i get no sound (internal speakers mute).

P.S. I know the solution but it seems to be ok post problem specific solution in form of question and answer.

share|improve this question
add comment

1 Answer

up vote 5 down vote accepted

The solution is to add line

options snd-hda-intel model=thinkpad

to the /etc/modprobe.d/alsa-base.conf.

After that you have to reload alsa:

killall pulseaudio
sudo alsa force-reload
pulseaudio -D

This can be applicable on other thinkpad laptops.

You can also try different models (see HdaIntelSoundHowto at help.ubuntu.com).

If this method doesn't help you can to try to debug hda-intel using HDA Analyzer. For example for my laptop I could use:

/usr/local/bin/hda-verb /dev/snd/hwC0D0 0x01c SET_PIN_WIDGET_CONTROL 0x40

to enable sound on external speakers. But it is not very good solution since you have to do it manually each time you plug external speakers.

hda-verb program can be downloaded from ftp://ftp.suse.com/pub/people/tiwai/misc/hda-verb-0.3.tar.gz.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.