Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The problem is, I have used Ubuntu from 6.10 upto 11.10. And upto 11.04 I used my same USB 3G dongle to connect to broadband and it worked fine. But 2 days ago I upgraded to Ubuntu 11.10 and broadband is not working. It detects my dongle and creates a connection without a problem, but when connecting it just keeps on and on for a long time and then say I'm offline. So I did a clean install and the same thing occurred.

But I also have a netbook and its got Ubuntu 11.10. I tried using the same dongle for internet on that netbook and it worked fine without any issues. But this isn't a problem with my USB port on my main machine or something like that because I'm also using Windows on my main machine (dual-boot) and its working fine.

My hardware:

  • Main computer (one that I'm trying to connect):

    • 2.8GHz dual core Intel
    • 2GB RAM
    • 500GB Sata II HDD
    • 384MB Video Memory (Intel G31/G33 chipset)
    • Ubuntu 11.10 (32bit)
  • My NetBook (broadband working fine):

    • 1.6GHz Intel Atom (dual core)
    • 1GB DDR3 RAM
    • 250GB HDD
    • 128MB Video Memory (Intel something-I-can't-remember)
    • Ubuntu 11.10 (32bit)

My dongle is a Huawei E220 and ISP is Dialog GSM (I'm in Sri Lanka)

So any idea why this is? I really love Ubuntu and this is bugging me off.. Any help greatly appreciated.

Regards, Roshnal

share|improve this question

4 Answers 4

up vote 2 down vote accepted

I was experiencing this problem for my E220 on Ubuntu 11.10 and 12.04 as well. It works sometimes and sometimes the "just keeps on and on for a long time and then say I'm offline" thing happens. So to connect I have to do things like unplugging and re plugging the dongle, restarting the machine etc.

But now Huawei offers a Linux version of its Mobile Partner software. I found this software with a new E303 which I bought from Mobitel. I installed this software on my computer and this Mobile Partner detects the E220 dongle as well. It works fine and even allows SMS and all the data monitoring facilities.

So, my suggestion to you is to install the Linux version of Mobile Partner which comes with new dongles. Please be careful about the Linux versions of the Mobile Partner which are available online. Some people have complained that the installation changed their configuration files and couldn't connect to internet afterwords. So use the software which comes in a new dongle.

share|improve this answer

I solved this problem but not so elegantly.

In Disc utility, I unmounted and safely disassembled the unit CD Huawei. One minute after that, the 3G modem is recognized properly.

It works for me. I think the problem is the CD-Huawei and not the USB mass storage.

I have Ubuntu 12.04 and Huawei E156G (I think this is like E220).

share|improve this answer

It seems to be a bug for sure. You can try the workarounds given here - https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/868034

share|improve this answer
    
Looks like it. I'll check and answer soon. –  Roshnal Nov 24 '11 at 15:15
    
It IS a bug! Found the solution on the link you provided. Thanks for the help. But do you know why it only affects my main PC and not my NetBook? –  Roshnal Nov 26 '11 at 14:35
    
Can you let us know which workaround helped you, so that other get benefitted out of it. –  Shrijit Nov 28 '11 at 6:26

As @Shrijt has said, it was a bug and I found a temporary solution in the link he provided.

Execute the below line on the terminal:

sudo usb_modeswitch -v 0x12d1 -p 1003 -V 0x12d1 -P 1003 -R

And then unplug and replug the dongle. It will work until next restart.

But as all the posters on the Ubuntu Bug forum has said, no clear permanent fix have yet been made.

Some users have suggested to replace the USB dongle-handling packages of Ocelot with those of Natty. Don't know if it will work. I'll get back here as soon as I find a fix.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.