Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Printer MP6150 driver installed itself upon plugging in the printer. Printer is recognized (lsusb shows it) but does not mount. If the printer is recognized, the driver must be working (or?), but something is blocking the system from mounting the printer. Tried the usual things: power of printer, restart Ubuntu etc.

Listed below result of lsusb and fstab:

hans@kontor-linux:~$ lsusb

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 04a9:174a Canon, Inc. 
Bus 002 Device 002: ID 1058:1001 Western Digital Technologies, Inc. External Hard Disk [Elements]
Bus 004 Device 002: ID 046d:c517 Logitech, Inc. LX710 Cordless Desktop Laser

hans@kontor-linux:~$ sudo cat /etc/fstab [sudo] password for hans:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda6 during installation
UUID=eaf3b38d-1c81-4de9-98d4-3834d674ff6e /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=93a667d3-6132-45b5-ad51-1f8a46c5b437 none            swap    sw              0       0

Here is what I have tried:

  • Tried the HK link again, but no luck so far. However, I connected the printer wirelessly to router on other xp box.
  • Installing the driver from ppa:michael-gruz/canon doesn't work, but the driver is installed
share|improve this question
add comment

2 Answers

Posting on behalf of the OP:

Having messed around as described in thread below, this is what it boils down to:

Most printer and scanner drivers (MG,MP and MX series) are easily found in Ubuntu Software Center.

first add a PPA:

sudo add-apt-repository ppa:michael-gruz/canon
sudo apt-get update

Open software center:

Search for: "Canon cnijfilter", in list; pick driver for your printer series and "Canon Scangear", in list; pick driver for your scanner series

Both will install in a snap.

Afterwards, go to system settings/printers and add your printer. Note: Scanning as of now (nov.2011) works from Gimp only, which is actually okay. Printer may show as 'not mounted', but still works.

This PPA doesn't yet contain drivers for the MG5300 series, see this question to set it up manually:

share|improve this answer
add comment

I recently installed kubuntu 12.04 . I have a Canon MG2150. The printer application installs without a problem the printer (general driver canon mg2100 series). However, the scanner is another story, I downloaded ScanGear 1.8 - Linux version (deb) from the Canon webpage and installed it, then when i use GIMP, and click to "Create" appears now within the options Scangear, and from there it controls your scanner pretty much ok... I still have 30 GB with a windows 7 partition, windows office 2007 and no internet, to run some work or other programs when i have compatibility issues, but i hardly use it. Of course in windows i have too the original printer drivers. I´ve tried a lot of things but the above mentioned is the one that has worked for me...Now i dont have to go to windows to use my scanner. Hope this helps...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.