Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've upgraded to 11.10 from 11.04 on a Toshiba Satellite L305-S5907 and can't get Compiz to work anymore. Metacity runs in it's place and "compiz --replace" gives the following errors.

Checking if settings need to be migrated ...no
Checking if internal files need to be migrated ...no
Backend     : gconf
Integration : true
Profile     : unity
Adding plugins
Skipping upgrade com.canonical.unity.unity.01.upgrade
Skipping upgrade com.canonical.unity.unity.02.upgrade
Initializing core options...done
Initializing bailer options...done
Initializing detection options...done
Initializing composite options...done
Compiz (opengl) - Fatal: Root visual is not a GL visual
Compiz (bailer) - Info: Ensuring a shell for your session

lspci -v gives

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07) (prog-if 00 [VGA controller])
Subsystem: Toshiba America Info Systems Device ff67
Flags: bus master, fast devsel, latency 0, IRQ 45
Memory at 90000000 (64-bit, non-prefetchable) [size=4M]
Memory at 80000000 (64-bit, prefetchable) [size=256M]
I/O ports at 5110 [size=8]
Expansion ROM at <unassigned> [disabled]
Capabilities: <access denied>
Kernel driver in use: i915
Kernel modules: i915

I have uninstalled all non-Intel drivers and software packages(ATI, NVidia). Mesa is installed. Using the "compiz-check" script, I get:

Gathering information about your system...
Distribution:          Ubuntu 11.10
Desktop environment:   GNOME
Graphics chip:         Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
Driver in use:         Unknown
Rendering method:      None

Checking if it's possible to run Compiz on your system...  [SKIP]

Checking for hardware/setup problems...           [SKIP]

At least one check had to be skipped:
Error: No rendering method in use (AIGLX, Xgl or Nvidia)

I have purged and re-installed compiz with no luck. I have deleted all of the ~/.config/compiz* folders with no result. Nothing OpenGL works (e.g glxgears, games, etc). Tried Compiz Fusion but it doesn't switch over to compiz.

Thanks in advance for the help.

share|improve this question
1  
If you've solved your problem, you should add it as an answer to the question (you can't do this yet because you're new to the system, just wait 24 hours or so) –  Yi Jiang Nov 24 '11 at 14:48
1  
Please add your solution as an answer. –  RolandiXor Nov 24 '11 at 14:50

1 Answer 1

EDIT: I have edited my /etc/default/grub to have the line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=" 

Where previously was: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

I have also gone into gconf-editor in Desktop>Gnome>Applications>Window_manager and removed the current and default window manager entries entirely (not just change values).

THEN, compiz --replace works, if I set it to load at boot. What a pain.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.