Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I need to completely remove the indicator, no flags, no abbr. nothing! I was able to do it in 10.04 using a gconf key that has no scheme and I heard that a proper scheme will be available in 10.10 but I can't find anything.

share|improve this question
add comment

4 Answers 4

Press Alt+F2 and enter gconf-editor

Now navigate to apps-->gnome_settings_daemon-->plugins-->keyboard and uncheck active

Restart.

share|improve this answer
    
While it deactivates the indicator indeed, I can't switch layouts anymore (Alt+shift). –  Reda Lazri Oct 29 '10 at 16:01
add comment

By the way, if you're removing it because of the big ugly (redundant) image in the 10.10 keyboard indicator, I've got a solution to that. I created a set of SVG flag images. If you install them and activate "show flags" in your g-conf editor then the text and ugly image both disappear. In their place you just have the one (much smaller) input language flag. I've posted the SVG's and full instructions here: http://gnome-look.org/content/show.php/Language+Flags+for+Faenza+and+Elementary?content=133726

share|improve this answer
    
This entry would be a nice comment to the question but this is not an answer. –  marenostrum Oct 22 '10 at 15:35
    
Thanks for the suggestion, I already saw your work, I don't want anything there plus you didn't include Arabic, otherwise I'll use it. –  Reda Lazri Oct 29 '10 at 15:08
1  
Actually, I've fixed the flag sets to include several other language, including Arabic. –  monotasker Nov 4 '10 at 0:30
add comment
up vote 1 down vote accepted

This is a known bug

the key I was talking about is:

gconftool-2 -s /desktop/gnome/peripherals/keyboard/general/disable_indicator -t bool true

For pre-maverick only.

Thank you all for the input.

share|improve this answer
add comment

I have completely same task, and i have just solve it for myself by using icons with the sizes of 1px * 1px, this is not completely removal, but it's best solution i could found.

Steps:
1) download icons (for example from here)

2)Untar (expand) the downloaded file into the folder ~/.icons/flags. If there is no "flags" sub-folder just create it. Then you need to enable the display of flags for input languages in gconf:

3) Open gconf-editor (in Ubuntu type ALT-F2 to open the "run application" dialogue and then type "gconf-editor" without the quotes and press enter).

4) Navigate the folder tree to Desktop > Gnome > Peripherals > Keyboard > Indicator

5) Activate the check-box for "showFlags"

6) Find icons for your languages in folder ~/.icons/flags, for me it was us.svg and ru.svg. Open it in image editor like Inkscape, and resize to 1*1 px (in inkscape Shift+Ctrl+D), save it.

share|improve this answer
    
Nice hack, I currently use Faenza-Dark indicator icons, which comes with a nice keyboad icon. –  Reda Lazri Mar 28 '11 at 13:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.