Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Gnome Shell and I do not like Zeitgeist indexing all my files. This makes the overview search in gnome-shell very slow. I do not want the overview to search recent files, so I installed activity log manager to prevent zeitgeist's logging activity. I configured the log manager as below.

screenshot

But even after adding every folder, the files keep appearing in the overview under Recent Items. Is there any other software or tweak which will instruct zeitgeist to search only applications installed in my system and not my recent files.

share|improve this question
    
I am using Ubuntu 11.10 32-bit. And I want to prevent zeitgeist from logging recent items. –  Vivek Nov 24 '11 at 7:58
    
I have the same setup (Ubuntu 11.10, 32bit), and am abkle to use Activity Log Manager to restrict which directories are logged. (!?) Try the steps (I) suggested in: askubuntu.com/questions/43097/unity-search-not-working –  david6 Nov 24 '11 at 8:05
    
The files appear under recent items, even after I deleted activity.sqlite and activity.sqlite-journal. When I restart the system, the files appear again. –  Vivek Nov 24 '11 at 8:17
    
UPDATE:: I have checked my settings and re-tested. It is NOT working, although it was about 2 weeks ago. –  david6 Nov 24 '11 at 21:12
1  
This question is still unclear. You asked you are using gnome-shell and then talk about search in Dash. In GS, Dash is the launcher on left hand side and in Unity dash is what you get by pressing Super key. Please update your question –  Manish Sinha Feb 11 '12 at 15:41
show 2 more comments

3 Answers

As far as I understand the Recent Items have nothing to do with Zeitgeist.

You could try the instructions made in the answer of this question.

share|improve this answer
add comment

I removed and re-installed Zeitgeist Activity Log Manager. This now appears to be working, but there are still images / documents in Dash history that should have been excluded.

zeitgeist-daemon --quit

sudo apt-get purge activity-log-manager 
sudo apt-get install activity-log-manager

zeitgeist-daemon -r &

I think Unity may auto-start zeitgeist-daemon, and that the blacklists' stopped working intermittently (after updates?) over the last two walso eeks.

I also tried Zeitgeist Activity Journal, and manually removed entries that should not have been logged (for last 2 weeks). The software is quite cumbersome, but will hopefully improve soon.

sudo apt-get install gnome-activity-journal

(loads as: 'Activity Journal')

hint: in ThumbView mode - use drop-down button (top-right), enable Erase Mode

This may have fixed issue, but I have NOT identifies any root-cause ..

share|improve this answer
    
If you are on precise, a new version is already available. Look for Privacy in System Settings –  Manish Sinha Feb 8 '12 at 17:48
add comment

Use GTK+ Recent Files Scrubber for deleting things appearing in gtk-open-dialogues via blacklists.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.