Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Yes, I have seen the other similar questions; if this is a duplicate please link me to the question that answer this, because none of them appear to; all appear to only address (1) of the two issues below:

There are TWO times when the sidebar will magically vanish:

1) By default when you move your cursor off it and focus on a different app.

This is fixable by setting the auto hide behaviour, as described here: How to make the Unity launcher always visible?

2) When you move a window over / under it, or maximize a window.

Even when the autohide setting is 'never' this will cause the sidebar to mysterious decide to hide itself. In fact, it doesn't appear what settings you change, this behaviour refuses to change.

This is extremely undesired behaviour.

I'm using a stock standard 11.10 install.

I've ALSO uploaded a video to youtube showing this not working in a virtual machine here:

http://youtu.be/aSjRP6-Miho

The steps to reproduce are very simple:

  1. Install ubuntu on virtual box (do not enable 3d acceleration)
  2. Set the hide behaviour

I can confirm that the setting DOES work when you swap to unity 3D. To reproduce:

  1. Install guest addons
  2. Stop your virtual machine
  3. Enable 3D acceleration
  4. Restart~

In summary, this seems to be an issue in unity 2d, not unity 3d. However, I still want a solution if anyone knows one. I run ubuntu as a vm in lots of situations and 3D acceleration is not always available.

Help!

share|improve this question
add comment

2 Answers

There are a couple of dconf settings you can use to control the launcher auto-hide capabilities.

12.04 & 11.10

To make the launcher always visible:

dcom write /com/canonical/unity-2d/launcher/use-strut true
dcom write /com/canonical/unity-2d/launcher/hide-mode 1

12.04

In 12.04 you can control this behaviour in a GUI.

enter image description here

As the picture shows - firefox overlaps the launcher but the launcher doesnt hide because the default is not to autohide.


Linked Question:

  1. How do I configure Unity 2D?
share|improve this answer
add comment

In CCSM choose unity plugin - hide launcher - choose never

this work for me in 11.10

share|improve this answer
    
You've actually tried this? You drag the window over the edge and the sidebar does not vanish? Does the window go under the sidebar, or over it? This is not the behaviour is see in a clean fresh brand new 11.10 install which has literally been installed and then had the compiz config installed and the sidebar changed to 'never' on the hide. –  Doug Nov 24 '11 at 13:03
    
Already answered here askubuntu.com/a/43708/34751 –  skumara Nov 30 '11 at 1:53
    
it really isnt. –  Doug Nov 30 '11 at 6:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.