Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Host OS: Mac OS X Lion Guest OS: Ubuntu 11.10 Virtualization: Vmware Fusion

I am the type of person that relies heavily on shortcuts. The fact that I don't have "Super" key on my Mac keyboard really bothers me. At first, I thought the apple/command key would be mapped to the "Super" key in Ubuntu by default, but it didn't work like that. How can I make "Super" key available to my setup? Thanks.

Below are shortcuts that involved the "Super" key. I have labelled the ones that didn't work for me.

Launcher

  • Hold Super - Invoke the Launcher.
  • Hold Super, then 1 or 2 or 3 and so on until 0 - Open or focus an application. The number corresponds to the location of the icon on the launcher from top to bottom.
    • Adding Shift will open a new instance of the application if it's already open.
    • Holding the key is also useful when you want to get to the Launcher but do not want to invoke the Dash.
  • Super-T - Open the rubbish bin/trash can.

Dash

  • Tap Super - Opens the Dash. The open signal is sent when you let go of the key, not when you push it down, so if it feels slow just let go of the key earlier.
  • (not working)Tab - 11.10+ only - Move to the next lens (When the dash is open)
  • (not working)Shift-Tab - 11.10+ only - Move to the previous lens (when the dash is open)
  • (not working)Super - A Open Applications lens
  • (not working)Super - F - Open Files & Folders lens
  • (not working)Super - M (11.10+ only) - Open the music lens

Window Management

  • (not working)Super - W - Spread mode, zoom out on all windows in all workspaces.

  • (not working)Super - D - Minimize all windows; hitting it again restores them.

Workspace Management

  • (not working)Super - S - Expo mode (for everything), zooms out on all the workspaces and lets you manage windows.
share|improve this question
add comment

2 Answers

If you Ubuntu will interpret the Windows/Start Menu key as the Super key then you can map it from the Keyboard & Mouse dialog in Fusion. From the VMware Fusion menu, select Preferences then go to the Keyboard & Mouse tab. From there you can add and delete keyboard mappings.

If the problem is that Ubuntu isn't interpreting the Windows key correctly, you should use the xmodmap command in a X startup file. For a complete tutorial try this link

share|improve this answer
    
thx for your response. I've checked the Keyboard & Mouse settings, and the Mac Command key is already mapped to the Windows key. It looks like my Ubuntu is not interpreting the Windows key as the Super key. Do you know how I can correct that? Thanks. –  tamakisquare Nov 24 '11 at 8:33
    
I edited my answer to include help on changing Ubuntu. –  kbyrd Nov 24 '11 at 14:15
    
I followed the instructions but that didn't make a difference in my case. I have tried all the shortcuts involving the "Super" key listed on this page. For some the Windows key behaves as the "Super" key while for the others it acts as a "Ctrl" key. I have updated my original post to reflect which shortcuts work and which ones don't. –  tamakisquare Nov 24 '11 at 22:38
    
I used logkeys to capture the key stroke from the Windows key. The result shows that the Windows key was interpreted as Meta key. Could this be the cause of the problem that I am experiencing? If so, any idea how could it be corrected? (I am so confused between the many different modifier keys out there) –  tamakisquare Nov 24 '11 at 23:02
add comment

In my case, all I had to do is disable the key mappings from fusion (i use the touchpad to swipe at osx level - no need for super-tab)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.