Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I need the driver for my wireless chip, and I don't know where to get it. Can anyone help?

P.S. The driver needed is a BCMWL4306. Also, tell me if I need to use NDISwrapper.

share|improve this question
    
Is it a BCMWL4306? I had that problem for a while, when I get home I'll see if I can find the right firmware. –  Kevin Nov 23 '11 at 20:02
    
Yes it is a BCMWL4306. thx. –  LinuxLover55 Nov 23 '11 at 20:13

3 Answers 3

I fixed the problem. my wifi card wasn't b43legacy, it was b43. I got it working from there. Thanks, anyway! :) – LinuxLover55 Jan 19 at 0:05

share|improve this answer

This worked for my friends compaq (I don't remember the model), worth a try.

Run in terminal

sudo apt-get update
sudo apt-get upgrade

Then you can activate the broadcom driver. (I would pop up or go to Dash-home then additional drivers)

share|improve this answer
    
I checked Add'l Drivers and the only thing I saw was the drivers for my nvidia graphics card which I already installed ;) Anyway, got anything else? –  LinuxLover55 Nov 23 '11 at 20:40

The driver for your card is the b43legacy.

sudo apt-get install firmware-b43legacy-installer

Then load the driver:

sudo modprobe b43legacy

And check if you can find the interface

ifconfig -a

Let me know if it worked.

Regards

share|improve this answer
    
That didn't quite work, but thanks for the suggestion. I put the line into the terminal and it seemed like it downloaded but when I went to add'l drivers, nothing new was there. –  LinuxLover55 Nov 24 '11 at 19:28
    
Hello! I updated my answer with other instructions. Can you please try this? –  Paulo Arruda Nov 25 '11 at 17:20
    
It worked! Hallelujah! wlan0 appeared with the eth0 and lo. I will see if I can detect my wireless network at my house. –  LinuxLover55 Nov 26 '11 at 6:03
    
It didn't quite work because my laptop still says that there is firmware missing for the wireless stuff. It says (in network settings), "device not ready (firmware missing)" Still don't get it. Any more detailed instructions? ;) –  LinuxLover55 Nov 26 '11 at 6:17
    
Hello all. I fixed the problem. my wifi card wasn't b43legacy, it was b43. I got it working from there. Thanks, anyway! :) –  LinuxLover55 Jan 19 '12 at 0:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.