Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've recently freshly reinstalled Ubuntu, and Mythbuntu, on all my computers.

On one of my computers, Mythbuntu 11.10, when I play a video, when it starts, I get a burst of white noise (static) that stays on.

If I stop the video and restart it, the noise goes away.

Sometimes if I fast forward or manipulate the video, the noise will start. It seems to be initiated, and stopped, by starting or interacting with the video.

Any ideas as to why this is happening and how I can get rid of it?


Now that I have some free time on the holidays, I've made a video of the problem and uploaded it here.

As you can see in the video, it starts playing normally. I hit the skip forward button a few times, and it's fine. After a few presses, you can hear the white noise burst. After that, the noise comes or goes at each press of the button. Each button press will randomly initiate or kill the white noise.

Also note that in the video it started without white noise. Sometimes, however, the white noise begins immediately on video start. Lastly, in the video I just pressed the skip forward and backward buttons. However, pause and and most any other button will also sometimes trigger the white noise.

I hope that makes much more clear what the problem is.

share|improve this question
    
We need more information. Can you post a screen record with sound? –  William Nov 29 '11 at 2:56
    
@William, I'll gladly post any information if I can. I'm not sure what you mean by a "screen record", though. Let alone how to do it "with sound". Can you be more specific? –  Questioner Nov 29 '11 at 4:01
    
Find a digital camera and take a video of you playing back a video on your computer. Point out where the white noise occurs. Upload the video. Who knows, maybe someone will spot something. It can never hurt to be more specific. –  William Nov 29 '11 at 4:06
    
@William: That won't work. It is not tied to a particular video or time on the video. It occurs randomly when I start, fast forward, or rewind videos. It does not happen at predictable places or with particular videos. –  Questioner Nov 29 '11 at 4:12
    
That is real odd. It's hard to fix a problem without predictably knowing when it will occur. Well, next time it happens grab the camera and record it. You've checked your sound card, I trust? –  William Nov 29 '11 at 4:18

2 Answers 2

up vote 2 down vote accepted
+200

To confirm if this is a pulseaudio issue, I would temporarily disable pulseaudio:

echo autospawn = no|tee -a ~/.pulse/client.conf && killall pulseaudio

Then in MythTv - Utilities/Setup - Setup - General change your Audio settings to ALSA:default

To revert to pulseaudio:

change the value of autospawn=no to autospawn=yes in ~/.pulse/client.conf

Then logout and login


Once confirmed as a PulseAudio issue, you perhaps have three choices:

  1. File a bug report with the MythTV developers and hope that they fix the issue. You'll need to be proactive with them to enable them to help you etc.
  2. Look at the existing 10.04 pulse-audio bug report and see if the same or similar patch can be done to the Oneiric MythTV sources - not for the faint-hearted!
  3. Look at just use ALSA:Default as the MythTV audio-setting. You shouldnt need to kill the host pulse-audio - thus multicasting etc should still work. You may need to enable the MythTV software controls to change sound settings. Alternatively/Additionally, install gnome-alsamixer or just alsamixer to control your audio settings such as volume, enabled speakers etc.
share|improve this answer
    
Thanks for this suggestion. I did as you said, and with MythTV set to use ALSA, the white noise problem does not occur. Setting it back to Pulse Audio makes the problem return. So, it would seem Pulse Audio is the culprit. I'm hoping there is a solution that lets me use Pulse as my audio driver, though, because it's with Pulse that I forward sound from various computers over the network to each other. –  Questioner Jan 3 '12 at 6:30
    
I use the Pulse Audio network server, as per the instructions in this question: askubuntu.com/questions/70556/… –  Questioner Jan 3 '12 at 10:37
    
Two further questions... If you have pulseaudio running as default on logon - does MythTV have the ability to still use the Audio Setting "ALSA:default"? If it does, does this fix the noise issue, and still leave the multicast facility of Pulseaudio working? –  fossfreedom Jan 3 '12 at 11:09
1  
Good idea! I left the system using Pulse, but changed within the MythTV interface to use "ALSA:Default", and it works. I also had to set the "Sound Mixer" setting to "software" on the next page of the MythTV settings, otherwise I didn't have volume control. Looking good. I'm going to let this run for a bit just to make sure no new problems come up, but this is looking promising as a solution. –  Questioner Jan 3 '12 at 13:19
    
ok - sounds promising. Dont forget you can also install alsamixer and gnome-alsamixer to give you fine control over your alsa settings (for example surround/5.1 speaker control etc) over and beyond what mythtv gives you. –  fossfreedom Jan 3 '12 at 14:01

Some applications can directly access to your sound card or using PulseAudio, or they use different solutions such as ALSA, and this is the main reason why you are experiencing this kind of problem only with certain software.

The solution is really tricky, because different sound cards can have really different behaviour, and with that i mean "really really really really different", also different application can use different framework.

try to change the output with the gstreamer-properties dialog menu.

or you can try this https://bugs.launchpad.net/ubuntu/lucid/+source/mythtv/+bug/550100/comments/8 that is a post from this topic https://bugs.launchpad.net/ubuntu/lucid/+source/mythtv/+bug/550100

share|improve this answer
    
Thank you for responding. The problem described in the bug report you link to seems to match my problem exactly. However, I am not skilled enough to apply the patch offered. Which is to say, I have no idea how or where to applay a patch. I only know how to uninstall or install deb packages, and maybe edit a configuration file or two. –  Questioner Dec 3 '11 at 14:28
    
for your convenience i think that the best move is to open a new topic about building patch from diff files mentioning the name of the lib you are targeting, the links above and your needs. I honestly do not know how to build a patch as described in the post linked above so i can't help you on this and probably can be too messy doing that in a topic with a little bit different argument like this one. –  Micro Dec 3 '11 at 14:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.