Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Lenovo z570 i3, Ive installed the packages available for nvidia and my graphics card is still not recognised?

It displays the following error upon trying to configure it

You do not appear to be using the NVIDIA X driver. Please edit your X configuration file and restart the X server

Any ideas?

share|improve this question
BY any chance is your laptop using Nvidia Optimus techonology? (Intel Graphics+ Nvidia Graphics) – Uri Herrera Nov 23 '11 at 17:34
I am not sure about the datasheet (…)... but could it be that no nVIDIA graphics is included?! – lgarzo Nov 23 '11 at 17:47
GT540M GPU, i7 CPU. This is certainly an Optimus model. See Bruno's answer. – Lekensteyn Nov 23 '11 at 20:53
@Lekensteyn I'm far from arguing with Bruno, I am just stuck at the i3 processor, since not all i3 ones have the nVIDIA chip. But if there is a big sticker somewhere on the chassis... – lgarzo Nov 24 '11 at 10:00
@lgarzo The i3 GPU can still have a dGPU. If you've a nVidia card, have you tried Bumblebee? – Lekensteyn Nov 24 '11 at 16:43

You laptop has a hybrid card, you have a intel + nvidia card running in your system, the drivers you are installing for you nvidia are not working correctly because they are not being loaded on startup.

You Intel card is running as primary so you have 2 options:

1) If you BIOS allows to turn off the Intel card and leave the nVidia one running then the drivers will work correctly;

2) Use software that enables you to use some functions of your nVidia card, its called Bumblebee and its largelly discussed on use/installation, etc, on the site.

share|improve this answer

with the Z570 there is a switch on the front of the laptop flick it and then you can make the Nvidia your primary graphics card in the nvidia settings

share|improve this answer

Under the 11.04 and laters the default driver for the Nvidia cards are the nouveau but they can't be installed on the same machine with the official nvidia driver, so you have to purge that package before installing the nvidia closed source driver.

sudo apt-get --purge remove xserver-xorg-video-nouveau

after that install the driver trough jockey-gtk ( "Additional drivers" dialog )

gksudo jockey-gtk

After that you can manage your configuration files with the nvidia-settings package, so install it with

sudo apt-get install nvidia-settings

and start the control panel with

gksudo nvidia-settings

this is the right procedure in a nutshell, looking at your report you probably miss the config files so if you do not want to do by hand install and use the nvidia-settings utility.

share|improve this answer

protected by Community May 28 '13 at 9:15

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.