Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been recently trying to find a solution for this on the web but did not find something useful or accurate for Ubuntu 11.10. I also consulted the NVIDIA help, but things there did not work for me.

I installed the additional drivers from system settings but they are not fully compatible with my GeForce 6200. First I tried finding how to stop the X server. I succeeded, but another problem was the nouveau kernel.

This is really frustrating. Can anybody tell me an accurate and authentic way to install NVIDIA drivers?

share|improve this question
    
Which drivers have you installed using the additional driver installation in system settings? Maybe you should just install an older version for your graphics card. I think the older version is version 96. –  Hannes Nov 23 '11 at 19:39
add comment

6 Answers

I just did this last night. Here is what I did.

  1. Copy all instructions down somewhere or cut & paste to a text file you can read on a virtual console - you will be completing this without a graphical user interface.
  2. Download the appropriate Linux driver from nvidia.com. It comes as a "self extracting archive" that you run just like a shell script. I changed permissions on the file after download was complete to make it executable (chmod +x << name of download file >>).
  3. Run sudo apt-get install build-essential linux-headers-`uname -r` in a terminal.
  4. At this point I switched to a virtual console (hold down Ctrl+Alt+F6 at the same time). By default Ubuntu seems to preconfigure 5 virtual consoles ... might come in handy to switch back and forth at some point. Just replace F6 with any function key from F1 to F5.
  5. Shutdown X-Windows: sudo service lightdm stop
  6. Remove old version drivers: sudo apt-get --purge remove $(dpkg -l | grep nvidia | awk '{print $2}')
  7. Run the downloaded script from NVIDIA and follow all of its prompts: sudo <script>
  8. Reboot.

At one point the NVIDIA script complained about some pre-install script having an error and gave me the option to continue or not - I continued. Seems to be working.

No warranties expressed or implied - use at your own risk. :)

share|improve this answer
1  
i dont know why but the third step was not executing, however using another way i installed the nvidia drivers successfully(by disabling nouevau and stopping x server) but now the problem is that ubuntu is showing flashing symbol( _ ) which appears everytime i boot into ubuntu. by pressing ctrl+alt+F1 . i am able to boot into text mode but how to boot into graphical mode?? –  2d4skt Nov 24 '11 at 8:07
    
You will likely find in /var/log/Xorg.0.log some indication that the x server failed during start up. You could also try manually starting from your virtual console (what you called "booting into text mode") and typing sudo service lightdm start. I expect it to fail. As far as "step 3 failing" something wonky happened to the formatting of the command I typed. the "uname -r" part was supposed to be in single back quotes. The command uname-r is evaluated (telling you which kernal version you are running) and appended to the app-get command so you get the right version of headers. –  Don Nov 24 '11 at 20:21
add comment

This for me worked perfectly. I simply followed the steps and unity was running after a quick restart. Quick Authentic way to install Proprietary Drivers in Ubuntu

share|improve this answer
add comment

1) You must blacklist nouveau:

sudo touch /etc/modprobe.d/disable-nouveau.conf

sudo gedit /etc/modprobe.d/disable-nouveau.conf

Add the following two lines, save then close:

blacklist nouveau

options nouveau modeset=0

2) Restart Ubuntu into recovery mode. See the NOTE on the bottom.

3) Boot to a different run level: sudo init 3

4) Stop X: sudo services lightdm stop

5) Manually edit the xorg configuration file. If it doesn't exist, skip this step: use locate xorg.conf to check.

Remove the line:

  Driver "nv"

(or Driver "vesa") (or Driver "fbdev") and replace it with the line:

Driver "nvidia"

Remove the following lines:

Load "dri"
Load "GLCore"

In the Module section of the file, add the line (if it does not already exist):

Load "glx"

6) cd to the driver file and then install the driver: sudo sh NVIDIA-Linux-<version>.run

Make it an executable first if necessary: chmod +x NVIDIA-Linux-<version>.run

7) If you did not have an xorg.conf file to edit earlier, let the installer create a configuration file for you when it asks.

8) Startup X and restart Ubuntu: sudo services lightdm start

The steps above are what I have used and got it running successfully. You should see an NVIDIA logo on startup, just after the Ubuntu one.

Source: http://us.download.nvidia.com/XFree86/Linux-x86/290.10/README/index.html

share|improve this answer
add comment

I'm using nvidia-current driver with Ubuntu 12.10 for the GeForce 6200 card. I think the nvidia-current driver (in the main repository) is available for Ubuntu 11.10 but you probably should update to either 12.04 or 12.10 anyway.

share|improve this answer
add comment

A much better and possibly safer way to get the most recent graphics drivers is adding the Xorg-Edgers fresh X crack ppa to your sources. The line for your sources, instructions on how to use this ppa, warnings and notes on how to deactivate it are found on the Xorg-Edgers Launchpad page.

I strongly advice you to read these instructions as drivers on this page are not tested, experimental, and may even break your system.

Adding the ppa will automatically offer you newer versions or bugfixes, and in addition you will be much better off in case you need to remove a driver. This all can't be done as easily with drivers downloaded from the manufacturer.

share|improve this answer
add comment

I tried downloading a driver from NVidia's web site for Ubuntu 12.10 and it failed miserably. Best solution I've found is sudo apt-get install nvidia-current

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.