Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to use my school's WPA Enterprise network to access the internet with my Three-OS laptop. I currently have Windows7, Ubuntu11.10 and Backtrack5 installed.

  • I can use my home's WPA2 network without any issues with the 3 OS.

  • I can successfully connect to my school's network with the 3 OS but I can only browse the internet with windows7. Ubuntu network-manager and Backtrack WICD both say that I am connected to the Acces Point but I cannot browse the internet.

  • I have tried uninstalling network-manager and installing WICD but it did not solve the problem.

  • Every time I connect to the Access Point, I am able to browse the internet for about 10 seconds.

  • I have tried disabling IPV6

  • I have tried changing DNS.
share|improve this question

My instinct says that you should check if you have to configure a proxy in your Ubuntu Browser. Maybe there's a config in your school's network that sends an automatic proxy configuration to your browser, and your ubuntu browser is not receiving it. Check it with the network administrator. If it's not the case...

Try do diagnose your problem following this steps:

1) Connect to the wireless network

2) Check your IP address with "ifconfig"

3) Check if your gateway is set correctly with "route -n"

4) Try to ping your gateway. Is it working?

5) Try to ping an internet IP like google: "ping"

6) Try to resolve names with "nslookup" for example.

7) Try to traceroute to an IP or name on internet. Check the result to see the last hop you reached.

8) If you passed all those tests, try this: "telnet 80"

If everything works, but not the test #8, your problem could be related to some proxy configuration. Please, update your question with any relevant information.


share|improve this answer

I want to comment, but not enough rep. :(

adding to Paulo's answer, if you can do step 5, but not 6, probably your DNS server is incorrect. check /etc/resolv.conf, add this line :


they are Google DNS server. You should able to lookup google now.

share|improve this answer
He's probably not in school anymore. – bc2946088 Apr 1 at 17:45
just realized I bumped this thing. sorry pal. – Rinaldo Jonathan Apr 1 at 17:50
" I want to comment, but not enough rep" That does not mean you can comment in the answer section, the answer section is for answers. You only need 50 rep to comment, try to earn it -1 – Mark Kirby Apr 1 at 18:00
you just made it harder to comment. just .... ugggh. – Rinaldo Jonathan Apr 25 at 17:53

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.