Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Problem: In Oneiric, Epson LP-S5500 doesn't work with the System Settings:Printing:Add Printer configuration, and says: Printer 'Epson-LP-S5500-2' requires the 'pstolps5500.sh' program but it is not currently installed. Please install it before using this printer.

I used this printer/PPD file ok with ubuntu 8.10. Here's the stuff I've done to get an Epson LP-S5500 (a Japan-market laser printer) working:

I installed pstolps5500.sh (came with PPD file from avasys, link below):

mcolman@O960:~/Dropbox$ pstolps5500.sh 
ERROR: /usr/local/bin/pstolps5500.sh: Un-known paper size

So is the problem telling Ubuntu CUPS setup where this helper script is located? how would I do this?

I also tried adding the printer from the CUPS interface at localhost:631, and also from the command line according to instructions that came with the PPD file, which came from http://www.avasys.jp/lx-bin2/linux/laser/DL1.do

Here's 2 commands for setting up direct usb connection printing, but there isn't a command giving for creating a network printer on the local network (there is a network printer creation command for the LP-S5000, I tried that and it created a printer but the printer didn't work...):

# lpadmin -p lps5500 -E -v usb:/dev/usb/lp0 -m Epson-LP-S5500-fm3.ppd
# /etc/init.d/cups restart

Sending test pages to the printer I set up on localhost:631 doesn't result in any printing, but the printer clicks. I can see ink levels though...

share|improve this question
    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. I am flagging this for closure. Regards, –  Ringtail Apr 3 '12 at 5:54

1 Answer 1

up vote 1 down vote accepted

The source package from avasys, combined with the instructions on the archlinux page below now allow me to print pages. The archlinux instructions have to be followed using ubuntu equivalents, like apt-get instead of pacman. Using the instructions, I set up an LP-S5000 and the same modification might work for other LP-S models.

I think the essential part comes right after this: "Edit the path of pstops in /usr/bin/pstolps5000.sh according to this"

http://www.avasys.jp/lx-bin2/linux/laser/DL2.do has the driver and https://wiki.archlinux.org/index.php/CUPS_printer-specific_problems tells how to configure the driver when building from source in order to make it work.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.