Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I get choppy sound output over hdmi with the command.

aplay /usr/share/sounds/alsa/Front_Center.wav

My current configuration can can be found here: output

Sound worked after some tweaking with 10.04. After upgrade to 11.10 sound stopped working properly. A fresh installation of 11.10 did not change the situation.

Video over hdmi works without problems. As soon as I run speaker-test I get fluent sound again. Workaround to trigger speaker-test after login is obvious but I would like a real fix to that problem.

How can I fix this?

share|improve this question
Check your cables and hardware. It should be a hardware problem. – Mykola May 2 '12 at 19:50

This problem was solved by the OP:

The following configuration fixed the problem:

1) Added the following line to /etc/pulse/

load-module module-alsa-siice=hw:0,8

2) Added the following line to /etc/modprobe.d/alsa-base.conf

options snd-hda-intel model=mbp55 enable=1 index=0 position_fix=1

The last three parameters actually solved the problem. Before that I had to run speaker-test to get fluent sound. dmesg returned the following error but afterwards sound was okay.

hda-intel: Invalid position buffer, using LPIB read method instead.

3) I am not sure if this is related but I had temporarily success with the following grub boot parameter in /etc/default/grub

GRUB_CMDLINE_LINUX="nomodeset noacpi"

I am still not sure what the problem was. If anyone could tell me I would like to learn it. Thanks.

Some useful resources:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.