Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I have been trying to read around about how to upgrade from the terminal. I am actually SSHing through putty to do all this. Anyways.. I first tried sudo apt-get update but since Jaunty is expired I needed to update my sources.

I updated my sources and apt-get update started to work. I then tried apt-get upgrade, and that resulted in some sort of dependency error. I then read apt-get dist-upgrade seems to make it work correctly. So it started installing a whole bunch of things before it got stuck. So finally the error message reads:

sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
  dmsetup: Depends: util-linux (> 2.16) but 2.14.2-1ubuntu4 is installed
  ifupdown: Depends: upstart-job
            Depends: initscripts (>= 2.88dsf-13.3) but 2.86.ds1-61ubuntu11 is installed
  initramfs-tools: Depends: util-linux (> 2.15~rc1) but 2.14.2-1ubuntu4 is installed
  libcompress-raw-bzip2-perl: Depends: perl (>= 5.12.4-1ubuntu2) but 5.10.0-19ubuntu1 is installed
                              Depends: perlapi-5.12.4
  libcompress-raw-zlib-perl: Depends: perl (>= 5.12.4-1ubuntu2) but 5.10.0-19ubuntu1 is installed
                             Depends: perlapi-5.12.4
  libdigest-sha1-perl: Depends: perl (>= 5.12.3-6ubuntu4) but 5.10.0-19ubuntu1 is installed
                       Depends: perlapi-5.12.3
  libhtml-parser-perl: Depends: perl (>= 5.12.3-6ubuntu3) but 5.10.0-19ubuntu1 is installed
                       Depends: perlapi-5.12.3
  libnet-ssleay-perl: Depends: perl (>= 5.12.3-6ubuntu4) but 5.10.0-19ubuntu1 is installed
                      Depends: perlapi-5.12.3
  libsocket6-perl: Depends: perl (>= 5.12.3-6ubuntu4) but 5.10.0-19ubuntu1 is installed
                   Depends: perlapi-5.12.3
  libwww-perl: Depends: liblwp-protocol-https-perl but it is not installed
               Depends: libwww-robotrules-perl but it is not installed
               Recommends: libhtml-form-perl but it is not installed
               Recommends: libhttp-daemon-perl but it is not installed
  module-init-tools: Depends: upstart-job
  mountall: Breaks: initscripts (< 2.88dsf-13.3) but 2.86.ds1-61ubuntu11 is installed
  plymouth: Depends: upstart-job
            Recommends: plymouth-theme-ubuntu-text but it is not installed or
                        plymouth-theme
  udev: Depends: upstart-job
        Depends: util-linux (> 2.15~rc2) but 2.14.2-1ubuntu4 is installed
E: Unmet dependencies. Try using -f.

When I try to individually install any of the above dependancies, it sort of throws me in a circle. I try installing one or multiple of them and then I get other dependency complains and I try to add or fix those and the other ones complain.

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

You cannot upgrade to oneiric using the method you've chosen.

You can only go through 9.10/10.04/10.10/11.04 to oneiric.

Rollback to a Jaunty using an image backup I'm sure you have made. Download the alternate CD for 9.10 and upgrade using that before moving through each upgrade sequence...

Or backup your vital files in your /home folder, do a clean 11.10 install and restore your files.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.