Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have 10.10 installed on a netbook with RT3090 hardware and the driver Ubuntu installed was of RT2800, it functions properly, but I decided to get the appropriate drivers, so I did the "make, make install" routine and restarted but the driver hasn't changed, and when I checked the "Additional Hardware" utility I see that the RT3090 driver is "activated but not in use". so my question is how to use it?

share|improve this question

The "Additional Hardware" utility (called jockey) sometimes doesn't behave correctly, when you compiled the drivers yourself. You can just deactivate the driver and then activate it again to accomplish what you want to do. After that, restart.

What happens "under the hood": jockey makes sure the driver is not blacklisted in /etc/modprobe.d/ and that other conflicting drivers are blacklisted.

If this doesn't work, do it by hand: First figure out the name of your current driver by running lsmod | grep mac80211.

mac80211              205402  1 ath5k
cfg80211              126496  3 ath5k,mac80211,ath

In this case the driver is ath5k. Prevent this driver from loading by adding the line blacklist ath5k to any file in /etc/modprobe.d/.

Now make sure your new driver (say ath_pci) is loaded on boot, by adding its name on a new line in the file /etc/modules.

share|improve this answer

Discussed Already. Basically, use only 32-bit and deal with the spotty connection until the drivers are updated to be more stable.

share|improve this answer

I had the same problem until I found an Internet source suggesting the following procedure. I tried it myself on my hp dv6 64bit version of ubuntu with the same wireless network card (Ralink RT 3090), and it worked.

Run this command in a Terminal window (Ctrl+Alt+T) or Run dialog (Alt+F2):

gksu gedit /etc/modules

This opens the /etc/modules file in a text editor.

Add this as a new line in the file:


Then save the file and close the text editor window. Then restart your computer and hopefully that will work just as it did for me.

It now connects to Wi-Fi without any problem what so ever, and the Additional Drivers tool now correctly says that the driver is installed and in use.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.