Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running ubuntu 11.04. I'm trying to install the latest "eclipse for java developers" IDE (version Indigo 3.7.1).

I have downloaded and extracted it. I attempt to run it by changing to the extracted folder and executing

./eclipse

This produces the following errors in the terminal:

> /usr/lib/gio/modules/libgiobamf.so: wrong ELF class: ELFCLASS64 Failed
> to load module: /usr/lib/gio/modules/libgiobamf.so
> /usr/lib/gio/modules/libgvfsdbus.so: wrong ELF class: ELFCLASS64
> Failed to load module: /usr/lib/gio/modules/libgvfsdbus.so

And then a dialog opens with this error message:

JVM terminated. Exit code=13 /usr/bin/java
-Dosgi.requiredJavaVersion=1.5
-XX:MaxPermSize=256m
-Xms40m
-Xmx384m
-jar /opt/eclipse//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
-os linux
-ws gtk
-arch x86
-showsplash
-launcher /opt/eclipse/eclipse
-name Eclipse
--launcher.library /opt/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.1.100.v20110505/eclipse_1407.so
-startup /opt/eclipse//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
--launcher.overrideVmargs
-exitdata 2f80031
-product org.eclipse.epp.package.java.product
-clean
-vm /usr/bin/java
-vmargs
-Dosgi.requiredJavaVersion=1.5
-XX:MaxPermSize=256m
-Xms40m
-Xmx384m
-jar /opt/eclipse//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar

I'd appreciate any help / insight.

Update

I should mention that I'm running 32 bit ubuntu and I'm trying to install 32 bit eclipse.

Update #2

Oops - I just realized that I'm running 64 bit ubuntu, not 32 bit ubuntu.

share|improve this question
    
:D so I was right –  binW Nov 23 '11 at 11:31
    
Ah, just saw "or vice versa" at the end of your first sentence. Thanks! –  James Nov 23 '11 at 11:34

2 Answers 2

up vote 4 down vote accepted

I believe this is because you are trying to run 64 bit eclipse on 32 bit system or vice versa. Make sure you are downloading the right version of Eclipse for your machine i.e if you are running 32 bit Ubuntu then download Eclipse for 32 bit Linux.

UPDATE:
The ELF error is indicating that the 32 bit application is trying to load a 64-bit shared library. It appears as somehow a 64 bit library got installed into /usr/lib. There are two open bugs for the above mentioned libraries:
https://bugs.launchpad.net/ubuntu/+source/gvfs/+bug/878135
https://bugs.launchpad.net/bamf/+bug/878129

share|improve this answer
    
Hi, I am running 32 bit ubuntu and I'm positive that I'm attempting to install 32 bit eclipse. –  James Nov 23 '11 at 8:06

Eclipse is not a 100% pure Java application. All the GUI-stuff happens in native code that must be supported by the underlying operating system, and your errors come from using a different version than the one you should use.

Download the correct version and try again.

If you do not need Eclipse 3.7 but can live just fine with a slightly older version of Eclipse, it is available as a package inside Ubuntu. For 11.10 it is Eclipse 3.6, I do not know about 11.04. I would suggest just finding it and installing it, or just run

sudo apt-get install eclipse
share|improve this answer
    
In 11.04 and older eclipse in repo's is Galileo(3.5), in 11.10 it's Indigo(3.7, the latest). –  foxy Nov 23 '11 at 9:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.