Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am confused by this, I have installed a lot of new packages and followed some tutorials after googling but I keep getting this kind of SASL -error. I am not sure whether the mistake is in some Gmail settings or should I check some settings in Ubuntu?

I thought this tutorial here would have solved this problem (i am simply trying to set up local mail reading with mutt, using gmail) but I cannot see the instructed things with telnet: "250-STARTTLS 250-AUTH PLAIN LOGIN" so that is why it is not working.

$cat .muttrc

set imap_user = "XYZ@gmail.com"  
set imap_pass = "pass"   
#set smtp_url = "smtp://name@smtp.gmail.com:465/"  
set smtp_url = "smtp://name@smtp.gmail.com:587/"    
set smtp_pass = "pass"  
set from = "XYZ@gmail.com"  
set realname = "name"    
set folder = "imaps://imap.gmail.com:993" 
set spoolfile = "+INBOX"  
set postponed="+[Gmail]/Drafts"    
set move = no
share|improve this question
1  
This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. Thanks! –  Mark Rooney Mar 24 '12 at 3:56
add comment

closed as too localized by Ringtail, hbdgaf, Tom Brossman, hhlp, Eric Carvalho Dec 31 '12 at 13:14

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

This

set smtp_url = "smtp://name@smtp.gmail.com:587/" 

should probably be

set smtp_url = "smtps://username@domain.ex@smtp.gmail.​​​com:465/"

2 differences:

  • use smpts and not smtp;
  • it is not clear if you meant that but name in your command should be like xxx@yyy.zz (not just the xxx in front of the @)

Also make sure

  • nutls-bin
  • openssl
  • libsasl2

are installed.

share|improve this answer
add comment