Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to run eclipse and I am getting:

/usr/lib/gio/modules/libgvfsdbus.so: wrong ELF class: ELFCLASS64 Failed to load module: /usr/lib/gio/modules/libgvfsdbus.so

I already found out that it is because this library is 64bits. I have found 32bit version of it and putted in subdirectory of /usr/lib32 but eclipse do not want to look for it there. How can I make it to look for libraries in /usr/lib32?

share|improve this question
    
How did you install eclipse? If you installed eclipse through the package manager, this should not be happening. –  Eliah Kagan Nov 23 '11 at 0:25
    
This should not even happen if eclipse has been downloaded from eclipse.org :) –  Sergey Nov 23 '11 at 0:34
add comment

1 Answer

up vote 1 down vote accepted

You're trying to run 32-bit eclipse (supposedly downloaded from eclipse.org, because Ubuntu package manager wouldn't let you do that) on 64-bit Ubuntu. While theoretically it may be possible to make this work, the easiest would be either to install eclipse using Ubuntu Software Center, or, if you have reasons to do so, download the proper installer from from eclipse.org

Their website has separate downloads for 32-bit and 64-bit Linux. You need the 64-bit one.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.