Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Ubuntu 11.10 (Oneiric) in VirtualBox as well as virtualbox-guest-additions Install virtualbox-guest-additions. The display resolution adapts to the size of the window as expected, but the display turns off after 10 minutes of inactivity. Thinking there was some sort of power management issue at play, I went to Power in the settings dialog:

enter image description here

There doesn't really seem to be anything there that mentions "turn off display after xxx minutes" so I assume everything is configured correctly there. Next I went to Screen and found an option there "Turn off after:".

enter image description here

Aha! I thought. Now I have found the option - but alas: even after setting it to "never" and restarting multiple times, the display still shuts off after 10 minutes.

What am I missing? What option am I overlooking?

share|improve this question
    
check this answer, under the same schema are timers for the screen, check if those affect that timer. –  Bruno Pereira Nov 22 '11 at 20:19
    
@GeorgeEdison Now that you've disabled the function that turns the screen off after a set interval of inactivity, I don't see a reason why you should have that Lock screen thing ON. Change it to OFF and see. It could be a bug. :) –  user33877 Nov 22 '11 at 20:54
    
@BadLearner: Good idea. –  Nathan Osman Nov 22 '11 at 21:09
    
@GeorgeEdison Did you try? Let us know if it worked. –  user33877 Nov 22 '11 at 21:10
    
@BadLearner: Unfortunately not. –  Nathan Osman Nov 22 '11 at 21:23

6 Answers 6

up vote 4 down vote accepted
+100

I note in the comments section that you have turned off power management.

Possibly you have run

gsettings set org.gnome.settings-daemon.plugins.power active false

Have you been playing with the alternative power management software xfce4-power-manager ?

Running xfce4-power-manager & via a terminal or xfce4-power-manager via startup applications, you can change when the monitor turns off - by default it is 10 minutes...

i.e. running xfce4-power-manager-settings

If you want gnome to be the default power management run

gsettings set org.gnome.settings-daemon.plugins.power active true in a terminal.

share|improve this answer
    
So should I try running that last command? –  Nathan Osman Nov 25 '11 at 22:26
    
In my answer I was assuming you were playing with various power management stuff and hence were no longer using gnome power management... if you want to go back to using gnome - then yes, run the last command. Alternatively, if you were using XFCE power management (IMHO - its better), use settings GUI to change the timeout value. –  fossfreedom Nov 25 '11 at 23:02
    
I don't have any XFCE stuff installed. I'll try the last command. –  Nathan Osman Nov 26 '11 at 1:03
    
IT WORKED! Enjoy your 125 rep! –  Nathan Osman Nov 26 '11 at 1:30

The blanking of a screen after 10 min is always suspect of DPMS & there were issues during 11.10 dev concerning that. But those where fixed & normally with the settings you've shown the screen should not blank.

Maybe this is a virtualbox issue - does your host Os blank after 10 min?

I guess you could additionally try this though shouldn't matter

gsettings set org.gnome.desktop.screensaver idle-activation-enabled false

And again no reason to but you could increase the time to idle

gsettings set org.gnome.desktop.session idle-delay 2400

A times in the past some have had to resort to an xorg section though again shouldn't be needed, could edit one in as a last chance ..

share|improve this answer
    
My host OS is Windows 8 and it is set to turn of the display after 30 minutes of inactivity... long after the guest OS has turned off its display. –  Nathan Osman Nov 22 '11 at 23:29
1  
What happens if you set it in System Settings to a time longer than 10 min, does it still blank @ 10 min? –  doug Nov 23 '11 at 6:04
    
It's already set to "never" in system settings. –  Nathan Osman Nov 23 '11 at 6:22
    
George - I was suggesting you pick a actual time & see if it blanks at the set time. So if set to 30 min does it blank at 30 or at 10 min. Also try one shorter than 10 min. like 2 min. if it blanks at 2 min but not at 30 min then i'd say your issue is DPMS & likely related to using in a Vm. If you want to try an xorg section I'll post one. (have you or can you try a live 11.10 session & see if the times over 10 min work? –  doug Nov 24 '11 at 8:21

With the Kubuntu 11.10 and predecessors there has been problems with the Energy Star features: http://kubuntuforums.net/forums/index.php?topic=3114757.0.

share|improve this answer
    
I'll try that and see if it works. –  Nathan Osman Nov 22 '11 at 20:09
    
Unfortunately it didn't work. –  Nathan Osman Nov 22 '11 at 20:26

i could find an alternative. Its a program called "caffeine" that disables power settings and screensaver settings while active. I was having the same problem as you, in Ubuntu 11.10. This should stop the screen from turning off. Try it and let me know: https://launchpad.net/~caffeine-developers/+archive/ppa/+packages

share|improve this answer

for a normal xfce4 desktop installation:

sudo xfce4-power-manager --customize

in the GUI you get with the above command change the culprit timer settings for display which seem to override the individual user account power settings.
Thats it!

share|improve this answer

The setting screen you're looking for is called "Brightness and Lock" not "Screen" or "Power".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.