Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a laptop with an Nvidia 310M card. I can't get my HDMI out to work in Ubuntu (I'm on 11.10 now, but this hasn't ever worked). My Windows partition works fine with HDMI.

I've tried disper and xrandr, neither show the external monitor connected.

Any tips to test/enable the HDMI interface?

share|improve this question

4 Answers 4

just in case it may help others:

I couldn get any sound using HDMI (graphic card: Nvidia Geforce GT 220) on Ubuntu11.10.

I clicked on System Settings/Additional Drivers.

Then select "NVIDIA accelerated graphics driver" and click activate.

After it's been downloaded and installed, reboot.

Then System Settings/Sound - Hardware: Select HDMI. Profile: Digital Stereo (HDMI) nr 2 Output -->>Important to select the profile. - Output: HDMI.

share|improve this answer
    
thanks but this is about video, not audio. –  julio Dec 30 '11 at 22:46

Are you using Nvidia's proprietary driver? I doubt that you will be able to get HDMI working unless you install the proprietary drivers.

Getting them installed can be a little tricky, but the first step is to head on over to Nvidia's driver download page and enter the appropriate information:

enter image description here

For example, if you are using the 32-bit version of Ubuntu, you would select "Linux 32-bit" and download this driver.

Once the download is complete, open a terminal in your downloads directory and run:

chmod 755 name_of_downloaded_file

...to make the file executable and then:

sudo ./name_of_downloaded_file

...to launch the installer.


Update: I totally forgot to write the instructions for actually enabling HDMI output. Run the following in a terminal:

sudo nvidia-settings

This will launch Nvidia's configuration utility. From there you need to click, "X Server Display Configuration" and click "Detect Displays" (assuming the HDMI cable is plugged in). Then it's simply a matter of configuring the display as per normal and applying the changes.

share|improve this answer
    
Hi George-- thanks for the info. I do have the latest nvidia proprietary drivers installed-- NVIDIA driver version is NVIDIA-Linux-x86_64-280.13 –  julio Nov 22 '11 at 20:15
    
I've edited my answer now. –  Nathan Osman Nov 22 '11 at 20:16
    
the nvidia utility doesn't detect the HDMI input either. –  julio Dec 12 '11 at 23:51
    
I would suggest double checking the cables and making sure the TV is using the appropriate input. –  Nathan Osman Dec 13 '11 at 0:03

Unfortuaately "pulesaudio" in Ubuntu * is also the likely culprit (regrading HDMI/audio) and there isn't much you can do about it. You're answer will be found right from nvidia: ftp://download.nvidia.com/XFree86/gpu-hdmi-audio-document/gpu-hdmi-audio.html#_issues_in_pulseaudio

I've also ensured that my (Ubuntu) Linux kernel is version 3.1 or higher, just in case..., but even then I still couldn't get HDMI/Audio to work properly. Basically, you'll need to use ALSA, nvidia designed their drivers around it. I could never understand why Canonical/Ubuntu stuck with such as piecs of "caca" as pulseaudio. ?! I have since migrated to (latest)Arch Linux/KDE/ALSA and ALL my HDMI/Audio output signals now work beautifully. Sorry, but that was my answer, becuase it worked for me.

share|improve this answer

I solved this problem on my sony laptop using the solution given here: http://ubuntuforums.org/showthread.php?t=1578004

share|improve this answer
3  
Welcome to Ask Ubuntu. While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. –  Peachy Aug 23 '12 at 15:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.