Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Lately, I've been experiencing laggy sound. The only usable syndrome I've found can be the fact, that is the Sound settings in the Output tab the Connector keeps changing to Analog Headphones from Analog Output, this takes only a few milliseconds before it jumps back to Analog Output.

This has been really annoying, because I can't play games, listen to music, and enjoy Ubuntu in all of it's beauty. Any help would be greatly appreciated. Thanks in advance.

share|improve this question
1  
For specifications see: intel.com/content/www/us/en/motherboards/desktop-motherboards/… It seems to be a Realtek ALC892. –  lgarzo Nov 22 '11 at 19:55
    
Thanks for clarifying mate. –  Shahe Tajiryan Nov 22 '11 at 19:58
    
1  
what was the point of the comment? –  Shahe Tajiryan Nov 22 '11 at 20:18
1  
nope.. Not a laptop :( –  Shahe Tajiryan Dec 8 '11 at 18:46

2 Answers 2

up vote 1 down vote accepted

Possibly this is a pulseaudio issue - one solution is to use ALSA instead of pulseaudio.

This will loose the sound indicator together with the pulseaudio tools. To change your sound use alsamixergui or gnome-alsamixer

sudo apt-get remove pulseaudio gstreamer0.10-pulseaudio
sudo apt-get autoremove
sudo apt-get install alsa-base alsa-tools alsa-tools-gui alsa-utils linux-sound-base alsamixergui gnome-alsamixer

Then reboot.

To reinstate pulseaudio:

sudo apt-get install ubuntu-desktop indicator-sound

As we have discussed, it is worth checking if this is a specific problem in 11.10 that could have been resolved in the upcoming 12.04 release. To do this, download either the Alpha 1 release of 12.04 or the daily-build.

Use Unetbootin to write the ISO to a USB stick and boot from that into the 12.04 live USB.

On confirmation that this is a specific 11.10 issue, then the problem is likely to be a kernel specific issue.

You have four choices:

  1. Stick with what you have and wait until 12.04 is officially released in April
  2. Upgrade to the 12.04 Alpha - only do this is you are prepared for breakages. Only do this if you are happy and experienced enough to overcome alpha quality issues such as non booting, graphical issues etc.
  3. Install 12.04 as a dual boot with 11.10 or as a virtualbox guest install in 11.10
  4. Upgrade the 11.10 kernel to the 12.04 kernel.

If you want to try the 12.04 kernel then first the important proviso:

drive-image backup you current 11.10 install

I'm not kidding - upgrading the kernel is not to be trivialised and can leave you in a non-booting scenario. Use a good quality drive-image software such as clonezilla.

Step 1 - temporarily change your sources to precise:

sudo sed -i -e 's/oneiric/precise/g' /etc/apt/sources.list

Step 2 - download and install the precise kernel

sudo apt-get update
sudo apt-get install linux-generic linux-headers-generic

Step 3 - change your sources back to oneiric:

sudo sed -i -e 's/precise/oneiric/g' /etc/apt/sources.list
sudo apt-get update

Then reboot.

Once logged in test that you have successfully booted into the kernel 3.2 by running:

uname -a
share|improve this answer
    
not working, all the same.. –  Shahe Tajiryan Dec 31 '11 at 11:43
    
Is there a way I can manually update my kernel to 3.2 with Ubuntu 11.10? –  Shahe Tajiryan Jan 4 '12 at 15:39
    
thanks ill try it later :) –  Shahe Tajiryan Jan 4 '12 at 20:05
    
Do you mean just booting from the live CD/USB and playing audio will be able to determine if the sound works as it should or not? –  Shahe Tajiryan Jan 5 '12 at 10:59
    
Banshee basically. Sometimes the Flash Player plugin for YouTube. And where can I get the Ubuntu 12.04 iso file? –  Shahe Tajiryan Jan 6 '12 at 13:19

I am not sure from your description if this is your problem or not, but try this workaround for glitchy (crackling, skipping) audio:

Using any editor, open /etc/pulse/default.pa

# command line
sudo -e /etc/pulse/default.pa

# graphical
gksu gedit /etc/pulse/default.pa

Find the line load-module module-udev-detect and add "tsched=0" to the end of the line

load-module module-udev-detect tsched=0

Log out and back in

Original post on the forums

Bug report

share|improve this answer
    
Did not work, same... –  Shahe Tajiryan Dec 11 '11 at 21:53
    
OK, try this driver files.spacefish.biz/LinuxPkg-5.15rc1.tar.bz2 Unpack it and run the install script as root. Then I would try rebooting –  bodhi.zazen Dec 11 '11 at 22:06
    
Installing the driver removed all my hardware from the Sound settings. But before installing the driver, I've noticed some detail, and it is pretty weird. When I go to Sound settings, in the "Output" tab the "Output volume" keeps going down for 5% or so in a few milliseconds and then jumps back to 100%, during this process (if the "Internal Audio Analog Stereo" is selected as the default device), the connector, just under the hardware selection jumps from "Analog output" to "Analog headphones" for the same few milliseconds. I do think that it is pretty weird, it can help though I think. –  Shahe Tajiryan Dec 12 '11 at 8:19
    
just to ask the obvious, did you reboot or at least restart pulse audio ? –  bodhi.zazen Dec 12 '11 at 13:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.