Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently updated the Linux kernel (via the Update Manager) to 3.0.0-13. I am running Ubuntu 11.10 using BURG.

Everything loaded correctly, BURG updated correctly. But when I reboot, when the GRUB screen comes on the monitor it only reflects 3.0.0-12.

I reloaded the Linux Kernel 3.0.0-13. Did the "update-burg" (see the results below), rebooted and still it loads GRUB window with the 3.0.0-12 kernel.

What am I doing wrong, or has anyone had this problem?

How do i fix this, I don't want to go mucking around with GRUB as I really don't know that much about it (i.e. manually configuring the GRUB/BURG files).

[14:22:52] xxxxxxxx@L01U1110:~$ sudo update-burg
Generating burg.cfg ...
Found linux image: /boot/vmlinuz-3.0.0-13-generic
Found initrd image: /boot/initrd.img-3.0.0-13-generic
Found linux image: /boot/vmlinuz-3.0.0-12-generic
Found initrd image: /boot/initrd.img-3.0.0-12-generic
Found Windows 7 (loader) on /dev/sda1
Found Ubuntu 11.04 (11.04) on /dev/sda5
done
share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Your title is slightly confusing, but I would try three things.

  • Go into the Software Center and search your version number (3.0.0-12) and uninstall the old kernel.

  • If it's BURG that's the problem, you can at least test that it's right by running burg-emu in a terminal. Otherwise, make sure that it's also installed on the drive that boots up, which is more than likely the first one:

    sudo burg-install ("hd0")
    sudo update-burg

  • Get GRUB Customizer (works with BURG) to manually check and modify which boot items are listed.

    sudo add-apt-repository ppa:danielrichter2007/grub-customizer
    sudo apt-get update
    sudo apt-get install grub-customizer

share|improve this answer
    
Sorry about the title. Let me try to explain. I did step #2 (burg-emu) and it shows up correctly in a BURG screen. BUT, when I reboot the window that comes up is a GRUB window, not the BURG window from the (burg-emu). It's like BURG is installed, but the OS is still looking at GRUB. I go into GRUB Customizer and it shows both 3.0.0-12 & 3.0.0-13. For what ever reason BURG is updated to the correct kernel version, but GRUB is not. –  user18432 Nov 22 '11 at 21:11
    
Sounds like burg didn't install to your boot drive, then. Did you try the burg-install ("hd0") line? It seems that for some reason, it hasn't overwritten the MBR to load instead of GRUB. I don't know if hd0 is correct, as I don't know your machine's setup, but I'd imagine you would know if it's different or not. –  Corey Nov 22 '11 at 21:30
    
BINGO, it worked. I guess BURG didn't completely install. But now it is perfect. THANK YOU so much for your help. I greatly appreciate it. –  user18432 Nov 22 '11 at 22:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.