Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After recent updates, desktop notification sounds stopped working. For example, sounds in pidgin no longer work. But when I go to Pidgin sound preferences and preview the sounds, they work. Also the sound in the applications work fine as usual. Could this be a bug or is there some workaround for this problem?

share|improve this question
    
Is there any application besides Pidgin in which sounds are not working? If it's just Pidgin whose sounds you're not hearing (but you hear them when you preview them), then uncheck Tools > Mute Sounds in Pidgin. –  Eliah Kagan Nov 22 '11 at 18:23
    
It is already unchecked. –  Guruprasad Nov 22 '11 at 18:36
    
The problem was that 'Enable sounds' in Tools->Preferences->Sound was set to 'Only when available' and some how my status was set a few days back to away. Changing 'Enable sounds' to always solved the problem. –  Guruprasad Nov 22 '11 at 18:41
    
@EliahKagan, Even the Ubuntu login sound I didn't hear. But I now found out that it is an issue with Ubuntu where I have to copy all the sound files from /usr/share/sounds/ubuntu/stereo to /usr/share/sounds. –  Guruprasad Nov 22 '11 at 18:43
add comment

5 Answers

up vote 1 down vote accepted

The problem with Pidgin was that 'Enable sounds' in Tools->Preferences->Sound was set to 'Only when available' and some how my status was set a few days back to away.

As for the other desktop notification sounds like the login sound - I found out that it is an issue with Ubuntu where I have to copy all the sound files from /usr/share/sounds/ubuntu/stereo to /usr/share/sounds. After doing that, the standard Ubuntu login sound played on login.

share|improve this answer
    
If this resolved your problem, could you please mark it as such by clicking the checkmark to the left of your answer? Thanks! –  WarriorIng64 Feb 25 '12 at 0:56
add comment

Actually, the standard notification sounds, which are set in system settings => sound will not work in Compiz, it seems. But it's not a sound problem; somehow, the actual event is not being sent. This is the sound used for errors or warnings. It includes the visual alerts that can be enabled in system settings => universal access (which has a button that triggers the sound + visual cue).

I found that it works correctly using Metacity, so I entered a bug report to Compiz.

share|improve this answer
add comment

For me, the solution was to:

  1. Open dconf-editor.
  2. Navigate to org.gnome.desktop.sound and enable event-sounds.
share|improve this answer
add comment

You need to add the following startup item to the startup applications.

Step 1: Click on the system menu at the top right of the screen (looks like a wheel)
Step 2: Click on startup applications
Step 3: Click add.
Step 4: Complete with the following:

Name: GNOME Login sound
Command: /usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login"
Comment: Startup Sound

Step 5: Click add.
Step 6: Click close in the bigger box.
Step 7: Log off and log in.

That worked for me.

share|improve this answer
add comment

using ubuntu 12.04, i installed ubuntu-tweak and on the Tweaks tab, enter the sound section and then enable Event sounds and choose a Sound theme (default "ubuntu").

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.