Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The WiFi on my Acer laptop (it's a 3810TZ, with Intel Corporation Centrino Wireless-N 1000) works flawlessly on Ubuntu 11.04. On 11.10, it's continually up and down, and it fills the system log with messages such as those below.

What is going on? It seems to be unable to decide which regulatory domain it's in. Despite the system configuration being quite clearly set to UK it persists in configuring itself as though it was opeating in Taiwan!

Nov 22 15:34:37 MES3810 wpa_supplicant[1053]: WPA: 4-Way Handshake failed - pre-shared key may be incorrect
Nov 22 15:34:37 MES3810 wpa_supplicant[1053]: CTRL-EVENT-DISCONNECTED bssid=00:50:7f:72:bf:b0 reason=15
Nov 22 15:34:37 MES3810 wpa_supplicant[1053]: CTRL-EVENT-DISCONNECTED bssid=00:00:00:00:00:00 reason=3
Nov 22 15:34:37 MES3810 kernel: [18239.240355] cfg80211: All devices are disconnected, going to restore regulatory settings
Nov 22 15:34:37 MES3810 kernel: [18239.240362] cfg80211: Restoring regulatory settings
Nov 22 15:34:37 MES3810 kernel: [18239.240368] cfg80211: Calling CRDA to update world regulatory domain
Nov 22 15:34:37 MES3810 kernel: [18239.240408] wlan0: deauthenticating from 00:50:7f:72:bf:b0 by local choice (reason=3)
Nov 22 15:34:37 MES3810 NetworkManager[875]:  (wlan0): supplicant interface state: 4-way handshake -> disconnected
Nov 22 15:34:37 MES3810 kernel: [18239.246556] cfg80211: Ignoring regulatory request Set by core since the driver uses its own custom regulatory domain 
Nov 22 15:34:37 MES3810 kernel: [18239.246563] cfg80211: World regulatory domain updated:
Nov 22 15:34:37 MES3810 kernel: [18239.246567] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Nov 22 15:34:37 MES3810 kernel: [18239.246572] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Nov 22 15:34:37 MES3810 kernel: [18239.246577] cfg80211:     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Nov 22 15:34:37 MES3810 kernel: [18239.246582] cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Nov 22 15:34:37 MES3810 kernel: [18239.246587] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Nov 22 15:34:37 MES3810 kernel: [18239.246592] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Nov 22 15:34:37 MES3810 NetworkManager[875]:  (wlan0): supplicant interface state: disconnected -> scanning
Nov 22 15:34:37 MES3810 wpa_supplicant[1053]: Trying to authenticate with 00:50:7f:72:bf:b0 (SSID='PoplarHouse' freq=2412 MHz)
Nov 22 15:34:37 MES3810 NetworkManager[875]:  (wlan0): supplicant interface state: scanning -> authenticating
Nov 22 15:34:37 MES3810 kernel: [18239.509877] wlan0: authenticate with 00:50:7f:72:bf:b0 (try 1)
Nov 22 15:34:37 MES3810 wpa_supplicant[1053]: Trying to associate with 00:50:7f:72:bf:b0 (SSID='PoplarHouse' freq=2412 MHz)
Nov 22 15:34:37 MES3810 kernel: [18239.512276] wlan0: authenticated
Nov 22 15:34:37 MES3810 kernel: [18239.512615] wlan0: associate with 00:50:7f:72:bf:b0 (try 1)
Nov 22 15:34:37 MES3810 NetworkManager[875]:  (wlan0): supplicant interface state: authenticating -> associating
Nov 22 15:34:37 MES3810 kernel: [18239.516508] wlan0: RX ReassocResp from 00:50:7f:72:bf:b0 (capab=0x431 status=0 aid=1)
Nov 22 15:34:37 MES3810 kernel: [18239.516514] wlan0: associated
Nov 22 15:34:37 MES3810 wpa_supplicant[1053]: Associated with 00:50:7f:72:bf:b0
Nov 22 15:34:37 MES3810 kernel: [18239.529097] cfg80211: Calling CRDA for country: TW
Nov 22 15:34:37 MES3810 NetworkManager[875]:  (wlan0): supplicant interface state: associating -> associated
Nov 22 15:34:37 MES3810 kernel: [18239.535680] cfg80211: Updating information on frequency 2412 MHz for a 20 MHz width channel with regulatory rule:
Nov 22 15:34:37 MES3810 kernel: [18239.535688] cfg80211: 2402000 KHz - 2472000 KHz @  KHz), (300 mBi, 2700 mBm)
Nov 22 15:34:37 MES3810 kernel: [18239.535692] cfg80211: Updating information on frequency 2417 MHz for a 20 MHz width channel with regulatory rule:
Nov 22 15:34:37 MES3810 kernel: [18239.535697] cfg80211: 2402000 KHz - 2472000 KHz @  KHz), (300 mBi, 2700 mBm)
Nov 22 15:34:37 MES3810 kernel: [18239.535702] cfg80211: Updating information on frequency 2422 MHz for a 20 MHz width channel with regulatory rule:
Nov 22 15:34:37 MES3810 kernel: [18239.535707] cfg80211: 2402000 KHz - 2472000 KHz @  KHz), (300 mBi, 2700 mBm)
Nov 22 15:34:37 MES3810 kernel: [18239.535711] cfg80211: Updating information on frequency 2427 MHz for a 20 MHz width channel with regulatory rule:
Nov 22 15:34:37 MES3810 kernel: [18239.535716] cfg80211: 2402000 KHz - 2472000 KHz @  KHz), (300 mBi, 2700 mBm)
Nov 22 15:34:37 MES3810 kernel: [18239.535720] cfg80211: Updating information on frequency 2432 MHz for a 20 MHz width channel with regulatory rule:
Nov 22 15:34:37 MES3810 kernel: [18239.535725] cfg80211: 2402000 KHz - 2472000 KHz @  KHz), (300 mBi, 2700 mBm)
Nov 22 15:34:37 MES3810 kernel: [18239.535730] cfg80211: Updating information on frequency 2437 MHz for a 20 MHz width channel with regulatory rule:
Nov 22 15:34:37 MES3810 kernel: [18239.535735] cfg80211: 2402000 KHz - 2472000 KHz @  KHz), (300 mBi, 2700 mBm)
Nov 22 15:34:37 MES3810 kernel: [18239.535739] cfg80211: Updating information on frequency 2442 MHz for a 20 MHz width channel with regulatory rule:
Nov 22 15:34:37 MES3810 kernel: [18239.535744] cfg80211: 2402000 KHz - 2472000 KHz @  KHz), (300 mBi, 2700 mBm)
Nov 22 15:34:37 MES3810 kernel: [18239.535748] cfg80211: Updating information on frequency 2447 MHz for a 20 MHz width channel with regulatory rule:
Nov 22 15:34:37 MES3810 kernel: [18239.535753] cfg80211: 2402000 KHz - 2472000 KHz @  KHz), (300 mBi, 2700 mBm)
Nov 22 15:34:37 MES3810 kernel: [18239.535757] cfg80211: Updating information on frequency 2452 MHz for a 20 MHz width channel with regulatory rule:
Nov 22 15:34:37 MES3810 kernel: [18239.535763] cfg80211: 2402000 KHz - 2472000 KHz @  KHz), (300 mBi, 2700 mBm)
Nov 22 15:34:37 MES3810 kernel: [18239.535767] cfg80211: Updating information on frequency 2457 MHz for a 20 MHz width channel with regulatory rule:
Nov 22 15:34:37 MES3810 kernel: [18239.535772] cfg80211: 2402000 KHz - 2472000 KHz @  KHz), (300 mBi, 2700 mBm)
Nov 22 15:34:37 MES3810 kernel: [18239.535777] cfg80211: Updating information on frequency 2462 MHz for a 20 MHz width channel with regulatory rule:
Nov 22 15:34:37 MES3810 kernel: [18239.535782] cfg80211: 2402000 KHz - 2472000 KHz @  KHz), (300 mBi, 2700 mBm)
Nov 22 15:34:37 MES3810 kernel: [18239.535786] cfg80211: Disabling freq 2467 MHz
Nov 22 15:34:37 MES3810 kernel: [18239.535789] cfg80211: Disabling freq 2472 MHz
Nov 22 15:34:37 MES3810 kernel: [18239.535794] cfg80211: Regulatory domain changed to country: TW
Nov 22 15:34:37 MES3810 kernel: [18239.535797] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Nov 22 15:34:37 MES3810 kernel: [18239.535802] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
Nov 22 15:34:37 MES3810 kernel: [18239.535807] cfg80211:     (5270000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
Nov 22 15:34:37 MES3810 kernel: [18239.535812] cfg80211:     (5735000 KHz - 5815000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
Nov 22 15:34:38 MES3810 NetworkManager[875]:  (wlan0): supplicant interface state: associated -> 4-way handshake

Any ideas?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Maybe there is a problem with the n-channel of your wifi.

Give the following terminal commands a try:

sudo rmmod iwlagn
sudo modprobe iwlagn 11n_disable=1

Try browsing again and if there is an improvement, make this change permanent by creating an 'options' file:

gksu gedit /etc/modprobe.d/options.conf
and add the line

options iwlagn 11n_disable=1

Hope this will help.

share|improve this answer
1  
That seems to have fixed it, at least the disconnects and all the log messages have gone away -- but at the cost of faster 802.11n wireless? Both my router and my laptop are supposed to support it. –  Mark Scott Jan 18 '12 at 22:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.