Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My question is about how I can install Ubuntu 11.10 packages on Ubuntu 10.04. I would like to install python-envisage (4.0.1), but in the Ubuntu 10.04 Software Center there is only python envisage v3.1.1. Also, the package is renamed from python-envisagecore to python-envisage.

share|improve this question

3 Answers 3

up vote 2 down vote accepted

Use some python package manager like: easy_install or pip, both are avaliable from the Software Center.

You should follow this steps:

  1. Remove any Envisage version installed through the Ubuntu package manager or any other way.
  2. Install easy_install.

  3. If the package that you are trying to install has C extensions (and Envisage does), you will need at to install at least this packages: build-essentials, python-dev. The points 2 and 3 can be both done with one command

    sudo apt-get install python-setup-tools python-dev build-essentials

  4. Finally open the console and type:

    sudo easy_install envisage

This should install version 4.0.0 (by fetching it from the official repos and compiling it, it will take a while).

You can install any package from the official python repos just with

sudo easy_install package

Pip works in a similar way, but it provides a uninstall facility. The main easy_install advantage is its popularity. If you want to use pip you will need to install the python-pip package instead of python-setuptools and use the following command (not tested):

pip install envisage
share|improve this answer

The software-center will have only the versions of software as available at the time of release of the distro. These versions are considered stable and only stability & security fixes are released.

Very rarely are complete new versions made available on stable releases - this is especially true for LTS releases.

The normal mechanism to test new versions of software is via testing PPAs - you can search for these on launchpad.net

I've had a quick look but have not found a v4 of python-envisage that has been backported for Lucid.

Thus a number of possible solutions (although not exhaustive...) are:

  • stick with the version you are using
  • upgrade to 11.10 (through 10.10 & 11.04)
  • install a virtualisation solution to run 11.10
  • dual boot with 11.10
  • ... and if you are feeling particularly brave - compile from source.
share|improve this answer
    
For python libraries (not for python apps), using a python native package manager (like easy_install or pip) is probably a saner solution. –  Javier Rivera Nov 22 '11 at 15:27

open synaptic package manager and try to give keywords in that then you will get the desired packages you want but before you do that you have to update your system completly. thanks

share|improve this answer
    
But, I don't want to update to Ubuntu 11.10. –  run Nov 22 '11 at 14:27
    
no need for update its your 10.04 updates i am saying about –  VENKI Nov 24 '11 at 18:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.