Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In order to edit which whitelisted apps are visible in the notification area, I normally could use dconf editor and edit from the unity panel entry as shown here.

The thing is, I have gnome fallback installed only, so the unity panel entry is obviously not present in dconf

So how can i edit the notification area, in order to remove the second battery icon that is visible?

Thanks for your help

(EDIT) here is a pic of what i need to remove, its the first battery icon, which is in the notification applet, not the indicator applet

panel

share|improve this question
1  
If you use the indicator-applet, I would assume that whitelisting will be the same as for Natty... askubuntu.com/questions/69377/… –  fossfreedom Nov 22 '11 at 14:05
    
thanks for the reply, but the issue is with the notification applet and not the indicator applet, thats why i have two battery icons, one in the indicator space, which is fine, and one in the notification applet which i want to get rid of –  Jayo Nov 22 '11 at 15:15
    
are you sure you havent just added the second battery applet? Try either WIN+ALT and right-click or ALT+right click over the battery icon and remove the applet. –  fossfreedom Nov 22 '11 at 20:31
    
no, its definitely in the notification applet –  Jayo Nov 22 '11 at 21:07
    
if you've installed the inidicator applet, why do you need the gnome notification area - surely just deleting this will resolve your issue? –  fossfreedom Nov 24 '11 at 15:44

3 Answers 3

up vote 5 down vote accepted
+50

In a nutshell, what you are trying to achieve is not possible. This is caused by a bug, which will be a bit difficult to solve, due to some changes in GNOME3.

  • There is not longer a separate gnome-power-manager process. It's now a plugin of gnome-settings-daemon.
  • If you disable the plugin, you will lose power management.
  • If you use another power manager, such as xfce4-power-manager, you will not get the indicator (which you want).
  • There is no system tray whitelist in GNOME Classic.

All in all, there is no direct solution, and your best bet is to wait until the bug is solved.


How to use xfce4-power-manager instead of GNOME Power Manager (the plugin) in GNOME 3

This will show you how to disable GNOME Power Manager in GNOME 3, and then how to enable xfce4-power-manager.

  • Install dconf-editor.
  • Navigate to org.gnome.setting-daemon.plugins.power and untick the active option.
    enter image description here
  • Install xfce4-power-manager (sudo apt-get install xfce4-power-manager).
  • Add this to your start up applications.
  • Log out and log back in.
  • You should now see a single battery icon, which will be provided by xfce4-power-manager.
share|improve this answer
    
if that is the case, is there any way to have the redshift and jupiter icon be visible in the indicator applet rather than the notification applet? (i recall when installing the radiotray app that it asks on first run where would i like the icon to be placed, so must be possible right?) –  Jayo Nov 24 '11 at 17:33
    
or if it isn't at all possible, how would i go about replacing the gnome power manager with the xfce power manager (which actually seems to have more control than the gnome manager funny enough) –  Jayo Nov 24 '11 at 19:55
    
@Jayo I believe Jupiter and Redshift have indicators; you just need to remove the notification applet (I think) to get them to show. As for the xfce4-power-manager question - I'll have to update my answer (not right now, but I will do it soon, if you don't mind). –  RolandiXor Nov 24 '11 at 20:08
    
not at all, of course i dont mind, any help is appreciated. its redshiftgui (a fork) im using rather than redshift, either way i had to enable the notification applet to get to see them to begin with, maybe its because in using gnome-fallback? –  Jayo Nov 24 '11 at 20:25
    
@Jayo most likely. I may have to do some testing manually to see if I can get them to show up, and then I will tell you the steps. –  RolandiXor Nov 24 '11 at 21:25

One solution is to remove the indicator and leave the notification icon:

sudo apt-get remove indicator-power

The indicator is more full-featured than the battery icon (which doesn't really do anything) but at least you'll only have one battery icon.

share|improve this answer

I have one solution with this ppa:jconti/gnome3.

It is simple, modify gnome-settings-daemon to hide the battery icon (like in unity) :

sudo apt-get build-dep gnome-settings-daemon
sudo apt-get install build-essential fakeroot devscripts
mkdir tmp
cd tmp
gedit patch_gnome-fallback.patch

Copy that in the patch_gnome-fallback.patch file:

--- gsd-power-manager.c 2012-02-05 21:27:41.000000000 +0100
+++ ../../gnome-settings-daemon-3.2.2/plugins/power/gsd-power-manager.c 2012-02-05 20:20:36.000000000 +0100
@@ -646,8 +646,7 @@
         if (manager->priv->previous_icon == NULL) {

                 /* set fallback icon */
-                if (g_strcmp0 (g_getenv ("XDG_CURRENT_DESKTOP"), "Unity") != 0)
-                        gtk_status_icon_set_visible (manager->priv->status_icon, TRUE);
+                gtk_status_icon_set_visible (manager->priv->status_icon, FALSE);
                 gtk_status_icon_set_from_gicon (manager->priv->status_icon, icon);
                 manager->priv->previous_icon = icon;
                 return TRUE;

Then run these commands:

apt-get source gnome-settings-daemon
cd gnome-settings-daemon-*/plugins/power
patch < ../../../patch_gnome-fallback.patch
cd ../..
debchange -i

[Tape some comments]

debuild -us -uc -i -I

And for the installation:

sudo debi

Restart and it works (if you have install indicator-power package).

Thanks to quantenemitter for the todo with another package https://bugs.launchpad.net/desktopnova/+bug/844983/comments/8

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.