Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 11.10 from a fresh install on a somewhat aged computer, so I have some speed problems. But since I do want to use the new cool way to work with things that Unity introduces I do not want to fiddle with getting another desktop environment.

My idea is to disable as much flair as possible, but there are tonnes of options that I do not understand or have the time to read up on when I launch CompizConfig Settings Manager. Which of these could safely be disabled?

Are there other places where performance could be gained by disabling things?

So how can I make the whole thing a little more snappy?

share|improve this question
1  
what graphic card do you have, and which driver are you using ? –  severin Nov 22 '11 at 13:20
add comment

3 Answers 3

Switch to Unity 2D? I've heard people say it's snappier, but I've not noticed any trouble with 3D myself.

That doesn't mean installing anything new - just click the "gear" icon on the login screen:

share|improve this answer
    
It works and looks much better, but how do I configure stuff like nr of workspaces and autohide on the launcher? –  UlfR Nov 22 '11 at 13:39
1  
dconf-editor and gconf-editor will need to be used to do that, there is no ccsm since your are not running compiz, have a look around and if you need help changing anything look around in the site, there are many questions on how to do stuff in Unity2D already. –  Bruno Pereira Nov 22 '11 at 13:45
1  
add comment

How to get better performance with unity-3d:

I have an ati hd3470 card and with the default settings, unity felt very sluggish, and some programs, like Sensible Soccer in dosbox, were unusable.

The following tweaks made a world of difference:

*Edit: This is of course only valid if you own a ati card r600 and newer.*

Install the fglrx driver.

Install compizconfig settingsmanager.

sudo apt-get install ccsm

Open compizconfig settingsmanager and

Disable Sync to VBlank. You will have tearing in Videos, however the performance gain for me was huge. enter image description here

Disable Blur of the Unity Dash. The readability of the dash will be worse, but I get better performance out of unity3d with blur disabled. Screenshot:enter image description here

After these tweaks, Unity-3d actually feels snappier than 2d.

share|improve this answer
    
Probably best to point out that fglrx is specific to ATI graphics cards, and the OP didn't yet say what he has. –  ams Nov 22 '11 at 15:34
    
Changed it, thought it would be clear because I stated my hd3470, but yes, you never know. –  severin Nov 22 '11 at 15:40
add comment

For Unity-3D, you might want to try using the Daniel van Vugt PPA for Compiz. There is a discussion of the performance issues with ATI fglrx drivers and improvements noticed with Daniel's fixes. Even on Intel, Compiz appears to run more fluidly using his builds.

His PPA is here: https://launchpad.net/~vanvugt/+archive/compiz

The bug report and discussion of his PPA is here: https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/763005

It's also possible to use Compiz with Unity-2D, I was able to get the most performance using this method. If you want to try this leave a comment and I'll add more info.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.