Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After today's update Nov. 22, 2011 Ubuntu option disappear from grub 11.10 on my dual partition.

some of fdisk -l:

Device Boot      System
/dev/sda1   *    HPFS/NTFS/exFAT
/dev/sda2        Extended
/dev/sda5        Linux
/dev/sda6        Linux swap / Solaris

Device Boot    ID System
/dev/sdb1   *  c  W95 FAT32 (LBA)

I also ran this:

 grub-probe -t device /boot/grub

to see where the grub was got this error:

 grub-probe: error: cannot find a device for /boot/grub (is /dev mounted?).

did this too:

 sudo update-grub

got the same error: /usr/sbin/grub-probe: error: cannot find a device for / (is /dev mounted?).

I also tried to boot repair Gui but it only shows MBR option and no grub. when I turn the computer on I get:

No such file:
grub rescue>

Any help would be much appreciated.

Edit: I also mounted the linux partition:

  sudo mount /dev/sda5 /mnt
  mount: /dev/sda5 already mounted or /mnt busy
  mount: according to mtab, /dev/sda5 is already mounted on /mnt

and ran the above commands and got the same errors as above.

Also did as tohuwawohu instructed:

umount /mnt
sudo fsck -p /dev/sda5
fsck from util-linux 2.19.1
/dev/sda5: clean,

Thanks again. Any Help would be awesome.

share|improve this question
    
I'm on a live Ubuntu 11.10 I did these commands via the terminal except ofcourse for the grub rescue> error which was on the actual computer which I got after using the Boot repair tool with live Ubuntu because the only option was restore MBR. –  st2011 Nov 22 '11 at 9:52
    
Hmm - maybe a file system issue? Did you run a file system check? Have you tried to proceed booting "manually" from the rescue prompt? –  tohuwawohu Nov 22 '11 at 10:03
    
To check the file system, unmount the partition (# umount /mnt) and start the check using # fsck -v /dev/sda5. Option -v gives verbose output. To automatically repair the file system, add a -p or -a. –  tohuwawohu Nov 22 '11 at 10:21
    
Another point: If your linux partition is mounted at /mnt, its /boot/grub directory is available at /mnt/boot/grub, not /boot/grub. You wrote you ran grub-probe -t device /boot/grub. –  tohuwawohu Nov 22 '11 at 10:33
    
@tohuwawohu your right. I get /dev/sda5 but when I do sudo update-grub I still get the same error as above. –  st2011 Nov 22 '11 at 10:42

1 Answer 1

up vote 1 down vote accepted

Maybe the boot repair tool will help (see also this answer). You can install it inside a live system using:

sudo add-apt-repository ppa:yannubuntu/boot-repair

sudo apt-get update && sudo apt-get install -y boot-repair && boot-repair

Here's some information how to proceed in grub rescue mode.

share|improve this answer
    
used the boot repair but that didn't have the option to fix or restore grub only restore MBR –  st2011 Nov 22 '11 at 9:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.