Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Ive just installed Ubuntu 11.10 and updated it. When I run Software Center it just sits at the loading screen forever. Software center did work before I added the canonical-partners source.

share|improve this question
up vote 1 down vote accepted

Just a suggestion:

Reinstall software center by doing the following:

  1. Open a terminal and type

    sudo apt-get install synaptic
  2. Then, run synaptic and type in the search field software center.

  3. In the results right click on software-center package and select "mark for complete removal".

  4. Click "mark" on the next dialog that tells you that also ubuntu-desktop will be removed. Then click the apply button and go on.

  5. Then, when the removal process is done, find again the software-center package, right click, and select mark for installation.

  6. Also find the ubuntu-desktop package and mark it for installation.

  7. Finally, click the apply button.
  8. Check then if Software Center gets stuck again on loading screen
share|improve this answer
Instead of uninstalling then reinstalling I selected mark for reinstallation which fixed it. – 11chubby11 Nov 29 '12 at 3:20

You could have stumbled into bug #891499. According to the bug comments, the following might help:

  1. Backup cataloged_times.p

    sudo cp /var/lib/apt-xapian-index/cataloged_times.p /var/lib/apt-xapian-index/cataloged_times.p.backup
  2. Delete cataloged_times.p

    sudo rm /var/lib/apt-xapian-index/cataloged_times.p
share|improve this answer
If you get permission problems, see this post. They suggest: sudo apt-get purge software-center apt-xapian-index && sudo rm -rf /var/cache/software-center && sudo apt-get install software-center apt-xapian-index – quantenemitter Nov 25 '11 at 9:29

Instead of uninstalling then reinstalling like Paul said, I selected mark for reinstallation. This fixed the Software Center.

share|improve this answer
Glad you fixed it ;) – Paul Nov 23 '11 at 17:48

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.