Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How do I add the korean keyboard typing system? I'm currently usins ubuntu 11.10.

I have tried adding the korean keyboard under setting>keyboard layout, but It doesn't allow me to type in korean.

share|improve this question
    
Just a quick info, using a key like tab,control or caps-lock etc. after typing 2 Korean syllables prevents them from being separated. It's not the best way to handle this 'bug' but at least it's better than having to go back and delete spaces between each syllable. –  snpnx Apr 16 '12 at 9:34
    
If you've followed the instructions below and the Korean layout is still behaving like Qwerty, go into Text Entry Settings and make sure you are using Korean (Hangul), not Korean. –  Josh Jan 10 at 16:20

3 Answers 3

I tried to find the answer to this last night and I got the same problem as you have. I having been trying again this morning. Is this what you want to do?

ㅂㅈㄷㄱ쇼 that is qwerty. Here is what I did:

1) Use System Settings>Language Support to select IBUS as the Keyboard Input Method System.

Adding IBus as keyboard input method system @ Language Support

2) Use Ubuntu Software Centre to install ibus-hangul.

3) Shut down and restart.

This should put a second keyboard icon in the top panel.

Click on it and select Preferences. Go to the Input Method tab and select Korean. Click Add.

Adding Korean input method @ IBus preferences

Now when you click on this second keyboard icon you can select Korean and a Korean icon will appear.

You can activate or deactivate the keyboard switching method by using Ctrl+Space.

Now if only I knew some Korean I could show off my success.

(사랑 우분투)

By the way this should work for Chinese as that is the other input method option.

Regards.

share|improve this answer

지 금 한국어 를 쓸 수있지 만 the spacing seems uncontrollable, so the syllables are breaking incorrectly. I wanted the first two symbols together, one word, meaning "now," but the input method kept splitting them apart.

At any rate, I had the same problem as Jorge, and already had steps 1-3 in Jame's response completed without any effect.

His answer inspired me to do the following, which got me to able to access Korean input, albeit with the problem identified above.

  1. Typed "input" into the dash, bringing up the screen above (in Jame's response).
  2. Clicked "input method switcher," and changed from default to use Ibus.
  3. When I closed this window, the wizard advised me to read a file (/usr/share/doc/im-switch/README.Debian.gz) and restart.
  4. I opened a terminal and tried reading the suggested file. The information did not seem relevant to Ibus, but suggested that the input method may be an area causing some bugs--something I might still need to consult. Then I restarted my system.
  5. I then clicked on the Ibus keyboard at the top left of my screen, and then preferences.
  6. In the preference window, I clicked on the middle tab "Input Method."
  7. Then I clicked on the "Select an input method," which gave me the choice of Korean or Chinese. I clicked on the Korean.
  8. Then clicked "ADD."
  9. Then I had the ability to switch from English to Korean! 그래 서 너 무 행복한다! Except for this weird spacing issue. Anyone have ideas for fixing the spacing? Doug
share|improve this answer

In the Unity Launcher, type in input. You will see a few options.

enter image description here

First go to Language Support. You should be able to select different formats to add to you profile by clicking "Install/Remove Languages".

After you have done this, you should be able to toggle between english and korean at the top right of your screen, next to your time and volume control.

If you are still having issues, type in Input once again from the unity launcher, and start

From there, I would also go to "Input Method Switcher"

Best of Luck!

share|improve this answer
    
I did every thing as you stated, but my ibus keyboard icon says I "No input window" when I have already added Korean. and I have Installed the languages and repeated the steps, ibus continues to say "No input windows". Is their any other way to get the Korean keyboard? –  Narnia Nov 22 '11 at 8:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.