Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using a Canon MP280 printer, which I found a driver from canon on the european site for. The print dialogue does not allow me to print in black and white unfortunately. Does anyone know of a way for me to force this? I'm guessing it is just a fault with my printer driver, but I feel like greyscale printing should be something in the OS sending the job, not in the printer drivers part.

share|improve this question
    
I'm using a Canon MP282 printer on ubuntu 12.10. After adding the CNGrayscale option and setting it to "true", black and white printing works for me. I found the options as described by Todd, without having to run "system-config-printer". It works like a charm! –  user140866 Mar 16 '13 at 22:16
add comment

5 Answers 5

up vote 3 down vote accepted

If you print to PDF first, you might have the option in there. If you don't (I don't for some reason), you can use imagemagick to convert a PDF from colour to greyscale in one command:

convert -density 600 -colorspace gray output.pdf output_greyscale.pdf

The -density 600 value is just there to preserve some quality as it rasterises text.

share|improve this answer
    
kind of roundabout but looks like it works (using imagemagick) –  bytewalls Feb 8 '12 at 17:47
add comment

I just solved this same problem talking to a Cannon tech rep over the phone. If your problem is that you ran out of ink on any of the other cartridges, but the black ones, all you have to do to force print is to hold the "stop" button for about 5 seconds. An up date screen will come up, after it's done, you can print. If the error screen comes up again indicating that another cartridge is out of ink also, just repeat the same process. Note: The tech guy warned me not to try to force print in color using this method, if you actually are out of ink on the color cartridges, as this will make the printer to force work, get over heated and permanently damage the unit.

share|improve this answer
add comment

To permanently change printing mode to "black only" do this:

On an internet browser go this webserver:

localhost:631

Then go to Printers (top right of the screen). On "queue name" click on the printer. Go to 'Administration' and select 'Modify Printer'. Choose the first 'usb' option and click continue. Next screen continue again. On the next screen select this printer in Model:

Canon PIXMA MP280 - CUPS+Gutenprint v5.2.9

And then for last click on 'Modify Printer'.

Exit the browser and change your printer settings.

On Lubuntu 13.04 Start Menu -> System tools -> Printers Choose properties on the MP280.

In the Printer Options screen. Choose: Color Mode: Greyscale Ink type: Black Ink set: Black

Click Apply and then OK.

Finally DONE!

share|improve this answer
add comment

If you want print grayscale in Ubuntu, and your printer is a Canon, the .ppd from Canon does not support the average black-white print.

You can search for edited .ppd files in Google that match and support black and white printing with your printer model. Replace your last .ppd and put the new .ppd in /usr/share/ppd.

Edit printer configuration (ubuntu 12.04)

Select dash -> printing -> chose your printer-> properties -> make and model -> provide .ppd -> choose the .ppd file that you downloaded and then change your .ppd

And then add CNGrayscale as above. I hope that help.

share|improve this answer
add comment

As outlined in this blogpost. I tested this on Canon MP280 using Ubuntu 12.04.

  1. Click System –> Administration –> Printing.

  2. Now right click on your printer and select Properties.

  3. Now select Job Options

  4. Now scroll down to the bottom.

  5. At the bottom you will see a text box . In that text box add CNGrayscale and click on Add button .

  6. Once you click add there will appear another text box right above the first text box . So in the second text box add "TRUE” and click on apply.

Thats all , now your printer will print in Grayscale mode . In case you want to print in color mode just change the TRUE to FALSE .

EDIT, In the 12.04.1 precise, these options are difficult to find.

You have to run the application "system-config-printer" in terminal or Alt-F2. Then you will always print in grayscale. No options are available in the menu. I am using mp280series_3.4-1. To print in colour you will have to run system-config-printer again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.