Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I used the newest vendor driver for my onboard NIC (board: ASUS M5A97 Pro) and those sites to get it running on kernel 3.0:

The problem now is, that this doesn't work with either kernel 3.1 or 3.2:

My question is: does anyone have a solution to get it run on the newest kernel? Or is this a plaque I have to carry forever?

share|improve this question

You could rephrase this whole question as:

If I run bleeding-edge software, will I be fine?

The obvious answer is no; you'll probably run into issues all the time. And that's what has happened here. Realtek (et al) and the community don't track the latest versions of everything and even when they do, they're not as fast as people who can run the latest kernel on the day of its release.

If you want better support, stick to a platform that people are using. Just because 3.1 is stable doesn't mean lots of people are using it.

In short: you don't have to carry the plaque but you will have to trade it in for the more-supported 3.0 kernel. You can't have your cake and eat it, I'm afraid.

If you want to try to minimise your pain, get in contact with Realtek now. I've no idea if they have a public bug tracking system that you can write to, but at the very least contact their support to make sure somebody there knows about the problem. It's not going to fix things overnight, but it might get you up and running within a month.

share|improve this answer

The newest version 8.0.26 of the Realtek driver plus some adjustment which can be found on the sites linked above, the nic works on the newest stable kernel 3.1.2. On 3.2, however, it still doesn't work, but hopefully Realtek will update the driver for newer kernel versions. But there will be a problem when you install a new distribution, since Ubuntu checks for updates on install for which you need a working nic. ;-)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.