Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu 11.04. Why the eth0 gets down, is there no tools or script to bring it up?

I tried several way, but none worked. Any idea?

1) vim /etc/network/interfaces

auto lo
iface lo inet loopback
auto eth0
iface eth0 inet dhcp

2) ifup eth0

a)

ssh stop/waiting
ssh start/running, process 1723

b) ifup eth0

ifup: interface eth0 already configured

3) restarted networkmanager but same no luck

Follow up:

1) sudo update-rc.d -f NetworkManager remove
2) sudo apt-get install dhcpcd
3) dhcpcd eth0
4) ifup eth0
share|improve this question

1 Answer 1

up vote 1 down vote accepted

What do you mean, "when it gets down"?

NetworkManager and /etc/network/interfaces are two separate ways of controlling the network, you should use one or the other. If you use NetworkManager, the interfaces file should be empty (everything commented out for eth0).

ifconfig -a output may help. Can you ping your default gateway? Or anything at all?

share|improve this answer
    
I can not ping anything at-all. And my total interface lights goes down when Ubuntu starts. –  YumYumYum Nov 21 '11 at 21:27
    
Now, after login with LiveCD, i do not have Eth0 up either. –  YumYumYum Nov 21 '11 at 21:39
    
You should consolidate as much relevant information as possible into the original question, including this. Post hardware details, output of appropriate parts of dmesg (grep for eth0, perhaps). –  Caesium Nov 21 '11 at 21:45
    
sudo dmesg | grep eth0; is showing eth0: link becomes ready –  YumYumYum Nov 21 '11 at 21:55
    
Do i have to install "apt-get install dhcpcd"? What does that do. –  YumYumYum Nov 21 '11 at 21:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.