Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

All: I am running Unity 3D and I want to set my launcher to never hide. I first ran ccsm, and set "Hide Launcher" to "Never". I rebooted then logged back in and it was still auto-hiding.

I then ran gconf-editor, I navigated to /apps/compiz-1/plugins/unityshell/screen0/options and then set launcher_hide_mode to 0. I again rebooted and logged back in. The launcher is still auto-hiding.

Checking gconf-editor, launcher_hide_mode is set to 0, but this setting isn't active however.

What can I do to get the launcher to Never hide?

Thanks,

Jim

share|improve this question
1  
are you absolutely sure that you are running unity 3d - you could be running unity 2D without knowing it... ? askubuntu.com/questions/62001/am-i-using-unity-or-unity-2d –  fossfreedom Nov 21 '11 at 16:01
    
Confirm version of Ubuntu. eg. 11.10, 11.04 . This Unity fix works for me (or using CCSM), and has done so for some time. –  david6 Apr 20 '12 at 23:41
add comment

1 Answer

You should run echo $DESKTOP_SESSION in a terminal to see what Unity version you are running. Especially when you updated your videocard drivers. Chances are something ent wrong and it falls back to 2d.

share|improve this answer
    
The question is about the hide behavior. Would the solution be different for 2D vs 3D? –  Keith Bentrup Jan 30 '12 at 19:08
    
Yes, Unity 3d (default if supported hardware/drivers) works with compiz, and Unity 2d doesn't. So changing settings in CCSM will have no effect if you are running Unity 2d. –  Timo Jan 31 '12 at 13:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.