Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to connect a bluetooth mouse to my Xubuntu system using Blueman (v. 1.21)

Problem seems to be bluetoothd not running at startup, so blueman refuses to start, only a dialog appears: "Bluez daemon is not running, blueman-manager cannot continue."

On my system, bluetoothd will run only as root (sudo), so my current workaround is simply to sudo bluetoothd manually, which works fine but id like to have it run at startup so that my mouse is just working without any interaction from me, if possible.

If i try to start bluetoothd as non-root it reports:

Bluetooth deamon 4.91
Unable to get on D-Bus

In the startup scripts i found the same bluetoothd script in all runlevels and init.d:

test -f /usr/sbin/bluetoothd || exit 0
#  bluetoothd normally starts up by udev rules.  it needs dbus to function,
log_progress_msg "bluetoothd"
pkill -TERM bluetoothd || true
log_progress_msg "bluetoothd"

I looked in /etc/udev/rules.d/ but no reference to bluetoothd.

Further i have already tried with no luck:

  1. Editing /etc/dbus-1/system.d/bluetooth.conf to include my user (essentially copying the part that was for root):

I tried it while both keeping the root policy and without, still, no luck!

  1. Editing /etc/pam.d/common-session and /etc/pam.d/gdm to include the line:

    session optional

In the case of common-session it was already there but with a "nox11" which i tried removing. No luck no luck.

Btw, I'm confused as to which session manager I'm using, since i have both xfce4-session and gdm-session-worker running.

Anyways, hope someone is savvy enough to figure it out or bring some hints, otherwise i sincerely apologize for wasting your time! I'll sign off with uname -a:

Linux [mycompname] 3.0.0-9-lowlatency #12ppa1~natty1-Ubuntu SMP PREEMPT Mon Aug 22 06:52:15 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Peace B)

share|improve this question

I assume this is the same bluez stack that's installed in Ubuntu, I'm using 11.10 as a reference. Regarding the dbus conf, it appears if you add your used to the 'bluetooth' group you should be able to speak to org,bluez.

 <!-- allow users of bluetooth group to communicate with hcid -->
 <policy group="bluetooth">
 <allow send_destination="org.bluez"/>

wrt to your bluetooth daemons script, it looks nothing at all like mine.

 dpkg -S init.d/bluetooth 
 bluez: /etc/init.d/bluetooth

I'm not a bluetooth expert but from the looks of what you're doing, that looks way off the beaten path. Bluez must have a regular method for profiling and autostarting devices. A little googling turned up this:

It doesn't look like blueman is doing the right thing for you, If you have to dive this deep into config files, it's doing more harm than good. I would recommend dumping it and sanitizing your bluez stack e.g. apt-get remove, dpkg --purge, and apt-get install. Then, starting from the bluez docs, configure and pair your mouse for auto-pairing at startup.

Blueman is also part of universe so it's easily possible that it's out of sync with our current stack and it's config changes are causing problems.

Hope that helps, good luck.

share|improve this answer
thx a lot i'll try updating – ffaxer Nov 21 '11 at 17:05

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.