Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got a problem with my EPG grabber script 'shepherd' for the Australian EPG. These two commands below work when I type it as user mythserver but when I put them in cron the first command creates a file of zero length:

# Collect data
18 13 * * * mythserver        /usr/bin/tv_grab_au --notimetest --output /home/mythserver/.mythtv/farm2.xmltv

# Read in data
30 4  * * * mythserver        /usr/bin/mythfilldatabase --file 1 /home/mythserver/.mythtv/farm2.xmltv

What am I missing here?

share|improve this question
    
Do you put the commands into the crontab manually? I believe shepherd can do this for you. If you do - which user's crontab do you use? –  Sergey Nov 21 '11 at 4:10
    
I'm putting them in manually because the automatic ones are not working and these are the work around commands. I've tried putting these into the users crontab using 'crontab -e' (without defining the user), but currently I have these two commands in my main /etc/crontab file. –  map7 Nov 21 '11 at 5:12

1 Answer 1

I would suggest to enable cron logging and see what exactly is happening. Googling finds the following instructions on enabling cron logging:

edit /etc/rsyslog.d/50-default.conf (uncomment the line starting with #cron.* - remove the # )

restart cron - sudo service rsyslog restart

I think the most likely cause of the problem is permissions although I don't see anything suspicious in your crontab

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.