Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've upgraded an Acer Timeline 4810T to Ubuntu 11.10. Everything works fine except for the darn wireless interface (network manager).

I just tested the wireless interface over a non-encrypted signal and it works beautifully. The issue is definitely related to WEP.

Unfortunately, some of the networks I need to connect to are WEP encrypted, therefore this is a serious issue for me that is preventing me from using Ubuntu on my laptop.

This was no problem in 11.04 and prior. Is there a simple solution for this? Any suggestions?

Here's more hardware information. Hopefully this helps to debug the network issue:

sudo lshw -class network

  *-network
       description: Wireless interface
       product: Centrino Wireless-N 1000
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 00
       serial: 00:1e:64:3c:5e:e0
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlagn driverversion=3.0.0-13-generic-pae firmware=39.31.5.1 build 35138 latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:43 memory:d2400000-d2401fff

lspci

02:00.0 Network controller: Intel Corporation Centrino Wireless-N 1000

rfkill list

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: acer-wireless: Wireless LAN
    Soft blocked: no
    Hard blocked: no

Many thanks for your help!

I just tested the wireless interface over a non-encrypted signal and it works beautifully.

The issue is definitely related to WEP.

Unfortunately, some of the networks I need to connect to are WEP encrypted, therefore this is a serious issue for me that is preventing me from using Ubuntu on my laptop.

Blacklisting acer-wmi module didn't have any noticeable effect and I reverted the change after testing.

blacklist acer-wmi

========

The following fix, suggested by Bruno, works:

options iwlagn 11n_disable=1

I did not go any further and did not try the second option provided.

share|improve this question
    
Have you asked why they are using WEP? This is hardly better than no encryption. If they want security, they need to be using WPA2 and/or RADIUS. –  david6 Nov 23 '11 at 1:27
    
The fact that they are using WEP is something I cannot influence or change. Ubuntu should still be able to do this without running into bugs. Will this be fixed for 12.04 or do I have to remember this workaround and re-apply it when I upgrade next time? –  noq38 Nov 24 '11 at 0:14
1  
If this 'public' site is providing WiFi-N, performance is always going to be an issue. The slower (and older) 'WiFi-G' shares the same 2.4GHz airspace, and the many 'WiFi-G' devices will adversely affect any devices using 'WiFi-N'. This will NOT be resolved until devices (and hot-spot services) start using 'WiFi-N' at 5GHz. See: tested.com/news/… –  david6 Nov 24 '11 at 0:31
    
Thanks, guys! That exhausts everything I wanted to know about this issue and the workaround is acceptable and no big deal at all. I'm very impressed with the level of your responses. Keep up the good work... –  noq38 Nov 24 '11 at 2:02
add comment

1 Answer 1

Edit the file (or create) /etc/modprobe.d/options.conf, add the line. If the file doesn't exist create it by doing:

sudoedit /etc/modprobe.d/options.conf

The system will then ask for your password and create this file. Then you need to add this line to it.

options iwlagn 11n_disable=1

or

options iwlagn 11n_disable50=1

Try each and see which works for you.

Reboot for testing on each line you are testing

sudo reboot

This will disable your N rated wireless access and connect it only with G speeds, if it works you are suffering a known bug (have to look the report for you, drop a comment if this worked). It wont be as fast as connection to a N rated wireless but at least will work.

If none of the 2 lines works for you just remove them to revert the effects.

share|improve this answer
    
I have a fresh install and the internet is not working although I seemed to be connected to the wireless connection. Tried your suggestions but still doesn't work, I dont know if my router uses WEP but works fine with other non linux computer, all works with linux in a virtual machine running from Windows –  Paul Taylor Mar 15 '13 at 18:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.