Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed turtlebot on my robot and also on the desktop. I am using the software on a 4XXX roomba. The baud rate is the same as the turtlebot. But, the port is not the same. I have tried and tried to edit the turtlebot_node.py configuration file and it will not let me save it. It says I don't have permissions.

When I try to change the permissions, it tells me that I am not the owner so i cannot change the permission. This happens on both the netbook AND the desktop. I am loss to what to do next. chmod and chown do not seem to work.

share|improve this question

1 Answer 1

Have you tried sudo -s at terminal before proceeding with chmod? If not, type at terminal sudo -s press ENTER input your system password and change to the file directory, at terminal type cd /type folder location here/ type filename here, next sudo chgrp type filename here press ENTER and sudo chmod g+rwx type filename press ENTER. I hope that would help out with the situation a bit. Thank you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.