Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First time on battery after installing Ubuntu 11.10. What I immediately notice is poor graphics performance and overall poor system responsiveness. If I plug in the power chord, it's all good. I am aware of the "battery drain" issue, but I wouldn't think it would affect the overall performance on the system.

Laptop: Dell Latitude E6500 - 8gm ram.

Any ideas? Google didn't return any results I found relevant.

share|improve this question
1  
Perhaps your CPU isn't scaling correctly, high swap usage, graphics dirvers...etc. –  Uri Herrera Nov 20 '11 at 21:36
add comment

2 Answers

First check is proper graphics driver installed for you system. Goto system setting>System Info>Graphics. If it is Unknown in driver section then ubuntu does not found proper driver for you graphics and running on low VGA mode.

Second, Any processor can run in multiple speed mode. As an example 2.1 GHZ core2Duo can run 1.2GHZ 1.3GZ 1.6GZ ... 2.1GHZ. To save power ubuntu run your processor in slowest mode. So solution is scale your cpu's frequency manually. (Don't worry it is very very very much safe, it is not over-clocking)

To do this install a indicator

sudo add-apt-repository ppa:artfwo/ppa
sudo apt-get update
sudo apt-get install indicator-cpufreq

After installation, run it (Press Alt+F2, write indicator-cpufreq which will add an icon in your ubuntu's system tray). Select "on-demand" which means cpu will be run in highest frequency it is necessary. If your cpu performance is low then select Performance from indicator which will run your cpu in highest speed all the time. Or you can select any frequency which is listed(supported by your cpu)

share|improve this answer
add comment

In addition to what shantanu said, the graphics processor may run in low-performance mode, when your computer runs on battery power.

For example, if you have AMD (ATi) GPU and propietary drivers, then you may have "PowerPlay" enabled. To disable it, go to Catalyst Control Center and you will find a "PowerPlay" page in the sidebar. This solved the problem on my Dell Studio 1558.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.