Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am experiencing quite major problem with Ubuntu 11.10.

Here is what happened: I installed the closed source video driver suggested by Ubuntu (my graphics card is ATI Mobility Radeon HD 560v). Having installed the driver I restarted the computer, and after that some parts of the Gnome UI didn't show up properly, wrong colors & unclear. I decided to remove the driver installed as everything had worked before installation, again rebooted my computer, but this time after showing the purple boot screen, whole screen turns black and nothing happens. I tried restart couple of times, same black screen instead of login screen.

The recovery mode of Ubuntu works so I can access terminal, only problem is that I don't know what to do.

Anyone got any ideas?

share|improve this question
up vote 2 down vote accepted

Be sure you have followed this guide to correctly install the proprietary driver

Also notice that there is a section of FAQ about problems and solutions, take a look at "Problems Starting Xserver"

share|improve this answer

Thanks a lot for the replies, I found solution from Micro's answer. It was in the wiki in the section you suggested.

All I had to do was run this command:

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.disabled
share|improve this answer

sudo apt-get purge fglrx and maybe sudo nano /etc/X11/xorg.conf, delete everything and save with ctrl O and enter.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.