Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Every time I start konversation, I get this screen:

It takes some 15 seconds …

How can I prevent it from coming up? I mean migrating once should be it.

share|improve this question

1 Answer 1

up vote 1 down vote accepted
+50

This is an open , upstream, kde bug

https://bugs.kde.org/show_bug.cgi?id=287673

Akonadi is invoked indirectly by the KDE PIM libraries, which Konversation uses for integration with the KDE address book. This integration currently cannot be disabled (although we're currently planning to change that).

For now, the only "work around" is to disable akonadi and use an alternate application (to konversation).

Note: disabling akonadi affects KAddressbook, Kmail, Kontact, KOrganizer, Konversation, Kopete, and any Widgets using these applications.

Disable akonadi

Edit ~/.config/akonadi/akonadiserverrc

kate ~/.config/akonadi/akonadiserverrc

And change StartServer=true to

[%General]
Driver=QMYSQL

[QMYSQL]
Name=akonadi
Host=
Options="UNIX_SOCKET=/home/your_user/.local/share/akonadi/socket-ufbt/mysql.socket"
ServerPath=/usr/sbin/mysqld-akonadi
StartServer=false

[Debug]
Tracer=null

Log out and back in or stop akonadi with

akonadictl stop

You can manually start akonadi with

akonadictl start

Un-do the edit to re-enable.

config

See also : http://ubuntuku.org/16/how-to-disable-nepomuk-akonadi/

share|improve this answer
    
Thanks. Those bungled, communicating applications seem to be a double edged sword … –  queueoverflow Dec 26 '11 at 21:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.