Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 11.10 and when I run "sudo shutdown 0", the computer doesn't shutdown. It gets stuck on "Disabling Power Management".

Any idea of what's happening?

Thanks in advance.

Also, this seems to happen more when using battery instead of AC.

share|improve this question

closed as too localized by jrg, Marco Ceppi Feb 3 '12 at 1:26

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Does running shutdown like: sudo shutdown -P now make any difference? –  Allu2 Nov 20 '11 at 15:27
    
What does -P change? I can't try it right now, but I will later. –  user25119 Nov 20 '11 at 16:28
    
Using -P worked. But is there a way I don't have to use it? Thanks. –  user25119 Nov 20 '11 at 17:54
    
Are you running a command-line only system, or do you have a GUI? If you have a command-line only system and you thus must shut down from the command-line, can you explain why sudo shutdown -P now is insufficient for your needs? If you have a GUI, then are you able to shut down by clicking the power/configuration icon at the upper-right corner of the screen and clicking Shut Down? –  Eliah Kagan Nov 21 '11 at 3:42
    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) –  jrg Feb 3 '12 at 1:25
add comment

1 Answer 1

man shutdown:

   -P     Requests that the system  be  powered  off  after  it  has  been
          brought down.
    ...

   -h     Requests  that  the system be either halted or powered off after
          it has been brought down, with the choice as to which left up to
          the system.

Seeing that -P works for you. Now it's a question of why not? The usual cmd to shutdown is shutdown -h now. In old school init based systems there was a config file that tweaks shutdown when entered from this point. From my initial investigation it turns out upstart falls back to init.d scripts to handle this. With global configuration living in /etc/default/halt and the actual script is /etc/init.d/halt.

It looks like "POWEROFF" is the default action, so if you just did halt or shutdown -h or telinit 0, it should also power off.

[/etc/init.d/halt]

    # If INIT_HALT=HALT don't poweroff.
    poweroff="-p"
    if [ "$INIT_HALT" = "HALT" ]
    then
            poweroff=""
    fi

Since INIT_HALT=POWEROFF (defined in /etc/default/halt), that poweroff='-p' stays set. To debug this it should be as simple as adding the vars populated at the end of the script like so.

 log_action_msg "Will now halt:  $netdown $poweroff $hddown"

I wonder if your shutdown cmds are simply overriding the init configuration? In which case telinit 0should also shutdown the server and should become the first choice in performing this action.

share|improve this answer
    
If -P doesn't address your issue then you might have an ACPI/BIOS bug worthy of a bug report. –  ppetraki Nov 20 '11 at 17:16
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.