Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since upgrading to 11.10 from 11.04 my laptop rapidly heats up and eventually turns off by itself (due to the intense heat I presume). This was not happening whilst running 11.04; I opted then to run gnome rather then unity, not sure if this makes a differences. Was hoping to solve this problem as it worries me that this continues to happen.

if anyone can help me, or i need to provide more information on my system please provide step by step instructions on how to do this as I am still a beginner to the linux platform.

share|improve this question
    
Is your laptop a Toshiba Satellite? –  Christopher Kyle Horton Nov 20 '11 at 21:19

3 Answers 3

This sounds like it might be a manifestation of the high power usage bug in the latest kernels.

There's a wiki page on it here: https://wiki.ubuntu.com/Kernel/PowerManagement

You might try installing and booting off the test kernels linked there to see if it fixes the issue. Ensure you get the correct ones for your Ubuntu version and architecture.

share|improve this answer
1  
If it is the pcie regression, its a lot faster to change the grub flag pcie_aspm=force than to up/downgrade the kernel. –  ppetraki Nov 22 '11 at 16:25

It seems you have the power regression/overheating bug with the Linux Kernel

this bug's fix is in one of the comments in this link.

How to downgrade Kernel

share|improve this answer

Go to the manufacturer of your computer/laptop model, check to see if there are updates for the BIOS for your model. (if you built it yourself you may need to go the motherboard's manufacturer site and check for BIOS updates.

Get the latest update if it is available. More often than not, there will be an .exe file you can use that will flash/update your BIOS for you. They may have one that will do it from DOS and one that will do it from Windows. I used the one for Windows. Follow the instructions. If your computer does not restart for you after BIOS update, restart your computer. Check your BIOS to see if you now have the latest BIOS update for your computer.

When I did this my computer had a senior moment at first. While using an alternative OS the fan would start then stop, start then stop, start then stop, then it worked normally even though I used Slax, Ubuntu (all version) and Slacko. Now I can use any OS I want to as long as I have the proper system requirements. No more overheating problems.

Warning: Be careful. Do not flash the wrong BIOS update for you computer/motherboard or your computer will be rendered useless.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.