Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I get an error where the monitor message says "Out of Range" (for installed Ubuntus while LIVE DVD =o.k.) and error "battery state"

In addition and probably related to this: the error message "battery state".

There are several threads on this site, related to this problem type. So far I did not find a really case-fitting solution and with an instruction easily to reproduce.

share|improve this question

1 Answer 1

I settled my problems with the long long procedure like listed here below. Hopeful that first time Linux users will appreciate to follow this excursion into the most powerful piece of an OS, the terminal window - instead of discarding LINUX forever after a first deception of this kind: "out of range".

See the same TRUE computing for all MS-Windows versions here:

http://aha7.com/ppp-en/cbwd-dos4win-en.htm

(Hence your instant re-activation of the now hidden and disguised "terminal window" inside all versions of MS-Window since 15 years.)

(Text modified 1 day later by the original author, only layout etc., to make it easier to reproduce the command line examples)

The main remaining question after the procedure (described here below) is:

I am a 10++ years LINUX user but not an expert. (Mainly Red Hat / Fedora.)

If the experts among the users of this site can add some additional information, this would be fine. It would be of interest what really has happened. Possibly, the NVIDIA drivers just were not yet aware of a new hardware... Perhaps, in such cases, now a driver package should be installed or updated?

I finally had to disable the most efficient of the NVIDIA drivers, perhaps due to their temporary problems. Will the existing new updated NVIDIA drivers now work properly? Atr perhaps installing them: Would I have to remove them instantly by the same procedure like - among othrs - described here below?

Now to the facts:

VERSION:

Ubuntu 11.10 - supplied with the periodical ct_Linux (Germany).

Hardware:

The problem apparently occurs for various hardware types. This specification of my hardware is only in order to have a sample case. New, just bought, and so far no reason to suppose any hardware fault:

MAINBOARD: Gigybyte M68MZ-D3P
CPU: AMD Athlon II X2 250 3GHz (take-over from reseller specification) CHIPSET: NVIDIA GeForce 7025nForce 620a GRAPHICS: Onboard - 1x D-Sub port (Connector: only VGA) RAM: 2x 2 GB

HARD DISK: 750 GB, 13 partitions. - /dev/sda1 =51 GB - exr4 - UBUNTU 11.10 installed - /dev/sda2 =51 GB - ext4 - planned for Linux Fedora 16 (=Red Hat) - /dev/sda3 =101 GB - FAT32 - reserve - for MS-Win - the following ones for data, average size 50 GB -

MONITOR 1: new 24'' : ASUS VH 242H -- data taken from reseller specification: LCD .- 23.6" - 1920x1080 - 300cd - 5ms - 20000:1 - HDMI - DVI-D - VGA - HDCP

MONITOR 2: (exactly the same boot problem...) old - 17" - standard LCD - Manufacturer or product name: "e-yama" -

(1) First: Test done with the LIVE version of UBUNTU 11.10: - 64b version -

No problem. Apparently works and properly displays as 1920x1080. 2 h software tests done, including Terminal, Firefox, Thunderbird, Gimp, Emacs, Kate (added). - All was and is apparently perfect.

(2) Installed: UBUNTU 11.10: - 64b version

This included the creation of partitions installed in /dev/sda1 (size 51 GB) - No problem stated during all steps of installing UBUNTU.

Internet access during installation =YES.

But automatic updates during installation: NOT permitted (disabled).

PC Boot placed on: sda

On /dev/sda1 : /

(This first HD partition will also hold all main directories von UBUNTU. I am using the PC only as am OS + Tool provider; my software creates a layer for computing on exteral devices with generalized OS portability.)

(3) Test of the installed version: "out of range"

After installation, then during the first boot:

The integrated monitor software displays: "out of range - Samsung". This is INSTANTLY after the BIOS message like "starting OS" or so.

There is no way to intervene, even not seconds, to interrupt for instructions or so.

Waiting several minutes during the ongoing boot procedure : This does not result in any change - nothing happens.

(4) Test of the installed version: With key "Enter"

When switching the monitor OFF, the key Enter results in some hard disk accesses. - Then switching the monitor to ON again: No effect - continuing monitor error messages.

One single time, for this kind of booting, I received instantly the message list in something like resolution 800/600 or lower, withPC halting after these 3 messages:

"Starting bluetooth"

"Pulsaudio... "

"checking battery state"

(5) Test on 17" monitor "e-yama" of the installed version: "out of range"

The boot procedure also did not succeed. It resulted in the same error message "out of range".

(6.1) Again with the UBUNTU LIVE version, boot from DVD:

Still worked properly - like above (1); even if NOT being connected to the Internet.

So all for a proper display for the used graphics hardware is surely included on the DVD, and detected automatically.

We just have a configuration problem during the initial boot from the hard disk.

=== now I opend the terminal window: (here in detail as a help for first time LINUX users:)

From the menu (left column, Top location: "dash" to the list of ALL applications. There clicked on "terminal". This now enables access to the installed version.

(6.2) checked from UBUNTU LIVE the installed version:

created during LIVE session in the LIVE file tree, as follows: (directory naming conforming to my personal habits:)

sudo mkdir /m ;

sudo mkdir /m/a01

sudo mount /dev/sda1 /m/a01

=== There is in fact the installed UBUNTU.

(6.3) show configuration of X11 :

=== show X11 config of HD version: command:

cat /m/a01/etc/X11/xorg.conf

=== result:

Section "Device"

            Identifier          "Default Device"

            Optin   "NoLogo"   "True"

EndSection

=== show X11 config of LIVE version: command: ls /m/a01/etc/X11/xorg.conf

=== result: file not found

=== Probably no need to change this: Because THIS configuration ("the current lack of such configuration") is probably not related to the boot problem. (??????????????)

(6.4) show the configuration definition of grub :

cat /m/a01/etc/default/grub

=== the result: Shows among others the following lines:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

GRUB_GFXMODE=640x480

=== In fact, from my DVD version, for the created UBUNTU installation, this line was outcommented, like shown here above.

(6.5) show the created configuration file of grub :

cat /m/a01/boot/grub/grub.cfg

=== show its creation date:

ls -l /m/a01/boot/grub/grub.cfg

=== the result shows among others the following lines:

export linux_gfx_mode

if [ "$linux_gfx_mode" "= "text"]; ]; then load_video: fi

(71) Set boot to the very basic monitor default:

REMARK: No success for (71) and (72). - Therefore (73) later here below will be required:

=== edit the setting, as follows:

sudo pico /m/a01/etc/default/grub

=== there remove the # from the line:

GRUB_GFXMODE=640x480

=== check if content and date have changed:

ls -l /m/a01/etc/default/grub

cat /m/a01/etc/default/grub

(72) Try to create the corresponding configuration file grub.cfg :

=== walk into the target directory: cd /m/a01/boot/grub

=== check current date and size: ls -l grub.cfg

=== The date shoul be that of installation - and the stated file size was 5447 bytes.

=== View what you plan to do: update-grub --help

(... I am not sure if that display perfectly fits to the action...)

=== create a dated backup: cp -pf grub.cfg gru_b-2011-11-20_12h.cfg

=== then try to write a new one: sudo /m/a01/usr/sbin/update-grub

=== - hoping that relative adressing will do the job properly and that the running LIVE environment has no influence on the future file content...

=== resulting message:

/usr/sbin/grub-probe: Error: cannot find a device for / (is /dev mounted?),

... did not work.... hence the next step is required:

(73) Force boot to the very basic monitor default, within grub.cfg

=== edit manually: sudo pico grub.cfg

=== insert the following line (just before line: " export linux_gfx_mode ")

set linux_gfx_mode=text

=== check if properly done: cat grub.cfg

(81) The first boot from the installed HD version after this modification:

  • leaving UBUNTU LIVE, starting with the version on the HD (=desktop PC)

During this boot, the control displays terminated with these 3 lines:

"Starting bluetooth"

"Pulsaudio... "

"checking battery state"

(82) Solving the problem with the "battery state"

The problem solution was found on askubuntu.com , in: Boot hangs after "Checking battery state..."

There I found the helpful key information:

"Got the same problem when something went wrong with my nvidia drivers.

  1. Wait to the checking battery state comes up.

  2. Try to go to a terminal login screen by pressing alt + F5

  3. Then remove the nvidia driver by typing:

sudo apt-get remove --purge nvidia-173 nvidia-current

  1. Restart by typing: sudo shutdown -r now

    " - (end of message)

On my PC, this was applied with the following result:

Only nividia-173 was found - and I ordered its removal, which dropped 34.2 MB (MB, not KB)

(82) Next boot: Nearly everything is o.k.

There is just a message, on the Ubuntu start page, that hardware-specific drivers might improve the result, e.g. for 3D effects display.

I intend to wait with this several months, in order to be sure that NVIDIA driver updates will then perhaps have learnt to deal with the used hardware combination.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.