Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
What is the easiest way to resolve apt-get BADSIG GPG errors?

i am getting these errors for a long time. At first they are not there . Please help me !!!

W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://archive.canonical.com oneiric Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key

W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://ppa.launchpad.net oneiric Release: The following signatures were invalid: BADSIG C2518248EEA14886 Launchpad VLC

share|improve this question

marked as duplicate by Lekensteyn, hhlp, Takkat, fossfreedom, Bruno Pereira Nov 20 '11 at 12:34

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

Please run the following at a terminal prompt:

sudo gpg --keyserver keyserver.ubuntu.com --recv-keys 40976EAF437D05B5 C2518248EEA14886
sudo gpg --export --armor C2518248EEA14886 | sudo apt-key add -
sudo gpg --export --armor 40976EAF437D05B5 | sudo apt-key add -
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.